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1. After the initial release of this book, a reviewer on Amazon.com pointed out that the iBooks Author EULA 
prohibits the sale of the .ibooks file specifically, which does not preclude you from selling the PDF output in 
other retail channels.

Preface

iBooks Author is the first tool of its kind. Never before have publishers, authors, and 
content creators had a tool for making dynamic, interactive books in a WYSIWYG 
environment. This book is intended to get you up and writing in iBooks Author. You’ll 
learn what to expect from this new tool and what its strengths and limitations are. You’ll 
see how you can create beautifully designed pages and how you can bring those designs 
to life with interactive content in ways that, before now, were only possible in a web 
browser on the Internet. You’ll also find out how to navigate the occasionally tricky 
terrain of Apple’s ecosystem so that you can get your book published to the iBookstore.

Things to Know and Consider Up Front
Before you start making your book, take a moment to understand just what you’re diving 
into by using Apple’s platform. The list that follows is not intended to scare you, but 
rather to give you the facts up front so that you can decide if iBooks Author is right for 
your project.
You will be able to sell your .ibooks file in the iBookstore only.1

If you use iBooks Author to create your book, you cannot export the file and sell it 
in any channel other than the iBookstore. You can’t sell it on your website. You 
can’t sell it on Amazon. You can’t sell it anywhere else. This restriction is included 
in the iBooks Author EULA (End User License Agreement) and specifically applies 
to the ebook format (.ibooks) and not the content of the book. The following is from 
version 1.0.1 of the EULA:

vii
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If you want to charge a fee for a work that includes files in the .ibooks format gen
erated using iBooks Author, you may only sell or distribute such work through 
Apple, and such distribution will be subject to a separate agreement with Apple. 
This restriction does not apply to the content of such works when distributed in a 
form that does not include files in the .ibooks format.

Note that the EULA explcitly states that the restriction does not apply to the content 
of your book, but only to the .ibooks file itself. You can always use the same content 
to create, sell, and distribute books and ebooks via other tools and methods.

Your book will work on only one device: an iPad.
Apple’s iBooks Author outputs files that are nonstandard and are specifically tail
ored for an iPad. You won’t be able to open them on any other reading device, 
including a Kindle or a NOOK. You won’t even be able to open your book on your 
desktop computer.

You will not be able to create print-ready PDFs.
If you have experience with traditional publishing tools such as FrameMaker or 
InDesign, you’re used to being able to output a CMYK PDF with printers’ marks. 
These options are not available. You can output a PDF, but it won’t be suitable for 
professional printing.

You will likely be entering into an agreement with Apple.
If you plan to publish to the iBookstore, you must apply for a seller account, of 
which there are two types: a Paid Books Account and a Free Books Account. It is 
in your best interest to consider up front which you will be using. You can read 
about each type of account in “Choosing Between a Paid and Free Account.”

Publishing with iBooks Author is not necessarily free.
While it is true that the application is free, there are costs associated with publishing 
a paid book in the iBookstore, including but not limited to the following:

• A single ISBN in the US costs $125 (see Chapter 6 for more information).
• Apple takes 30 percent of every sale that you make.

Read the Book Publisher FAQ to learn more about what to expect from working in 
Apple’s new ebook ecosystem.

Why iBooks Author Is Worth Considering
If you’re looking to create books that are digital first, use dynamic page designs, and are 
truly interactive, there is no better tool for the job than iBooks Author. Some readers 
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may quibble with that last sentence, but at the time of this writing it is undeniably true. 
iBooks Author is an innovative step forward in book making, and you have an oppor
tunity to be a part of that, whether you’re a publisher or just someone who has always 
wanted to write that cookbook but never knew where to start.

Despite the restrictions and limitations described in the previous section, iBooks Author 
may still be right for your book project. After all, developers have been using Apple’s 
tools and platforms to publish iPad and iPhone applications for years under similar 
types of restrictions. They’ve accepted the terms, and some have had tremendous suc
cess under those terms.

If you’re writing a simple fiction book, iBooks Author may be more than you need, 
unless superb digital page design is very important to you. Even then, it’s probably a 
good idea not to load your novel with video and interactivity; many readers find this 
more of a distraction than an enhancement. Step back and ask yourself, “What is this 
video/audio/widget adding to the reader experience?” (Again, this warning is meant 
just for you fiction writers—when it comes to reference books or learning materials, 
multimedia can add a great deal.)

Audience for This Book
This book is written for anyone who is interested in getting up and running in iBooks 
Author quickly. It assumes you know little about publishing and even less about ebook 
formats, a topic in which this book isn’t interested. Readers who are comfortable with 
Apple’s OS X applications in general will undoubtedly be more at ease learning about 
this particular application. This book assumes you know what a toolbar is and how to 
navigate your way through a standard OS X menu, but it also assumes that you’re look
ing at iBooks Author for the first time.

This book assumes you’re new to the Apple iTunes ecosystem and to its various tools 
and the peculiarities of its platform. It assumes, for example, that you do not already 
have an iTunes Connect account.

Conventions Used in This Book
The following typographical conventions are used in this book:
Plain text

Indicates menu titles, menu options, menu buttons, and keyboard accelerators 
(such as Alt and Ctrl).

Italic
Indicates new terms, URLs, email addresses, filenames, file extensions, pathnames, 
directories, and Unix utilities.
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Signifies a tip, suggestion, or general note.

Indicates a warning or caution.

How to Contact Us
Please address comments and questions concerning this book to the publisher:

O’Reilly Media, Inc.
1005 Gravenstein Highway North
Sebastopol, CA 95472
(800) 998-9938 (in the United States or Canada)
(707) 829-0515 (international or local)
(707) 829-0104 (fax)

We have a web page for this book, where we list errata, examples, and any additional 
information. You can access this page at:

http://www.oreilly.com/catalog/9781449329785

To comment or ask technical questions about this book, send email to:

bookquestions@oreilly.com

For more information about our books, courses, conferences, and news, see our website 
at http://www.oreilly.com.

Find us on Facebook: http://facebook.com/oreilly

Follow us on Twitter: http://twitter.com/oreillymedia

Watch us on YouTube: http://www.youtube.com/oreillymedia

Safari® Books Online
Safari Books Online (www.safaribooksonline.com) is an on-demand 
digital library that delivers expert content in both book and video 
form from the world’s leading authors in technology and business. 

Technology professionals, software developers, web designers, and business and crea
tive professionals use Safari Books Online as their primary resource for research, prob
lem solving, learning and certification training.
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Safari Books Online offers a range of product mixes and pricing programs for organi
zations, government agencies and individuals. Subscribers have access to thousands of 
books, training videos and prepublication manuscripts in one fully searchable database 
from publishers like O’Reilly Media, Prentice Hall Professional, Addison-Wesley Pro
fessional, Microsoft Press, Sams, Que, Peachpit Press, Focal Press, Cisco Press, John 
Wiley & Sons, Syngress, Morgan Kaufmann, IBM Redbooks, Packt, Adobe Press, FT 
Press, Apress, Manning, New Riders, McGraw-Hill, Jones & Bartlett, Course Technol
ogy, and dozens more. For more information about Safari Books Online, please visit us 
online.
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CHAPTER 1

Tour

Template Chooser
The first thing you see when you open iBooks Author is the Template Chooser 
(Figure 1-1). This is where you choose the general look of your book. You have six 
options: Basic, Contemporary, Modern Type, Classic, Editorial, and Craft. Each tem
plate has its own predefined styles and graphics for you to use. Most parts of the template 
can be changed, but not all. Only you can decide which template is right for you, but 
when you do, click it and select “Choose,” and Author opens up a brand new project 
for you, filled in with three or so spreads and dummy text.

Lorem Whatsum?
Author automatically fills the first few pages of your project with placeholder text com
monly referred to as “lorem ipsum” in the publishing and design worlds. The exact origins 
of lorem ipsum as a placeholder are foggy, but can be traced back to at least the 1960s, 
and might even go as far back as the 1600s. The text itself is a chopped-up version of 
sections 1.10.32–3 of Cicero’s De finibus bonorum et malorum. There’s some debate in 
design circles about the benefits of using nonsensical placeholder text versus real content 
to help preview your layout, but if you want to add some lorem ipsum of your own, go to 
http://www.lipsum.com/.

If you have second thoughts about your selection or clicked the wrong icon by mistake, 
don’t sweat it. Just click the red x in the top left corner of the editing screen, and then 
go to File → New from Template Chooser, which brings you back to—you guessed it—
the Template Chooser.
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Figure 1-1. When starting a new book project, your first step is to pick a template from 
the Template Chooser.

Interestingly, choosing File → New accomplishes exactly the same thing: bring
ing you back to the Template Chooser. If you want a blank slate for ultimate 
customization, the Basic template is the closest you can come.

Editing Window
Your next stop after the Template Chooser is the editing window. This is where you’ll 
spend the bulk of your time in Author, adding text and images and making your book 
look amazing. The editing window is divided into a few sections. The majority of it is 
devoted to your book. The panel on the left by default shows thumbnails of all the pages 
in your book, as well as a few options with basics like the title page and table of contents 
and extras like a glossary and media to add as an intro for your book.

To resize the editing window so it takes up more or less of your computer screen, just 
grab the resize handle in the lower right corner and drag to the desired size.

The editing window consists of a few sections by default: the Toolbar, the Format Bar, 
and your book pages.
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Figure 1-2. The Toolbar lets you keep your favorite tools at your fingertips. The Format 
Bar is your first stop to adjust the formatting of the elements on your page.

The Toolbar
Running along the top of the editing window is the Toolbar (Figure 1-2). This gives you 
quick access to some of the main tools you’ll be using. Your default tools in the Toolbar 
are: Add Pages (see “Adding Pages” (page 47)), View (see below), Orientation (see “Ori
entation” (page 5)), Text Box (see “Text Boxes” (page 41)), Shapes (see “Shapes” (page 
56)), Table (see “Tables” (page 43)), Charts (see “Charts” (page 57)), Widgets (see “Widg
ets” (page 58)), Preview (see “Previewing Your Book on the iPad” (page 85)), Publish (see 
“Submitting Your Book to the iBookstore” (page 86)), Inspector (see “Inspector” (page 
5)), Media, Colors, and Fonts.

Apple knows that the default tools aren’t going to cut it for everyone, so they give you 
an option to add (or remove) almost anything you want to the Toolbar. Go to View → 
Customize Toolbar... and drag any of the tools that you want to have at hand onto the 
Toolbar (see Figure 1-3). If you want to clear out your customizations, from the Cus
tomize Toolbar dialog box, drag the default set onto your Toolbar (outlined near the 
bottom of the dialog box).

View

The View button on the Toolbar lets you adjust the different parts you see in the editing 
window:

• Page Thumbnails. Choose this to show small page icons (called thumbnails) in the 
Book menu. You can choose either this or Book Outline, but not both, and you 
must choose one.

• Book Outline.  Instead of thumbnails, display the parts of your book in outline 
format.

• Glossary Toolbar. Adds an extra toolbar below the main Toolbar, so that you can 
quickly add new glossary terms on the fly (see “Glossary” (page 9)).

• Show/Hide Styles Drawer. Toggles the Styles Drawer open or closed. The Styles 
Drawer has all the built in or custom text styles for you to choose from. More on 
those in “Styles and the Styles Drawer” (page 34).
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Figure 1-3. Choose your favorite, most-used tools from the Customize Toolbar dialog 
(View → Customize Toolbar...). The default set of tools is outlined at the bottom of the 
dialog; click anywhere inside it and drag to the Toolbar to undo your customizations.

• Show/Hide Layouts. Inserts a new box at the top of the Book menu, with all the 
different page options for your chosen layout. Clicking one of the thumbnails gives 
you a preview of what that page layout looks like. There’s more on applying new 
layouts and adding pages in Chapter 5.

• Show/Hide Format Bar. Controls whether or not the Format Bar shows up at the 
top of the screen (see “The Format Bar” (page 6)).

• Show/Hide Rulers. Displays rulers along the top and left edge of your page display. 
Rulers come in handy when you’re working with paragraph indents and tabs 
(“Tabs” (page 31)), and when you’re adjusting the layout of your pages (see “Creating 
Complex Layouts (Tutorial)” (page 74)).

To change the units of measurement used in your rulers, go to Author → 
Preferences... → Rulers, and choose the style you prefer (inches, centimeters, 
points, or picas).

• Show/Hide Layout Boundaries. Turning this option on reveals the edges of your 
various frames, which is useful when arranging the elements on your pages, seeing 
where things overlap, and getting them in proportion.
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Figure 1-4. A page in landscape mode (left) and portrait mode (right). Your graphic layout 
items disappear in portrait, and widgets get pulled into the margin as icons.

• Show/Hide Invisibles. Shows hidden text markers and characters that are usually 
invisible. When you turn this on, spaces between words show up as small blue dots 
and you get a special glyph to mark the ends of all your paragraphs. Text fields—
strings of text that are used in multiple places, like chapter and section titles—are 
marked with a blue border.

Orientation

The two buttons here let you toggle between portrait and landscape mode (Figure 1-4). 
Portrait mode includes a very pared-down display of your content: all widgets appear 
as small icons in the margin and text scrolls up and down like a web page. Landscape 
mode is where you’ll do most of your work. You can create a book entirely in portrait 
mode without any bells and whistles, but why not take full advantage of iBooks Author, 
and create both kinds of pages? See “Assembling the Pages” (page 22) in Chapter 2 for 
more about the two different orientations.

Some graphics and text boxes don’t show up at all in portrait view, so be careful. 
See the warning in “Anchors” (page 53) for details.

Inspector

The Inspector is one of the most useful tools in the Toolbar, though it may not seem 
like it at first. Here you find tools to add metadata (see “Document Inspector” (page 11) 
at the end of this chapter); adjust the overall page layout (Chapter 5); customize text 
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Figure 1-5. The Format Bar contains basic formatting tools that change based on your 
selection, like text (top) and graphics (bottom).

wrap on objects; format text (“Text Inspector” (page 29)), graphics (“Images” (page 49)), 
and tables (“Tables” (page 43)); adjust charts (“Charts” (page 57)); add internal and ex
ternal hyperlinks and bookmarks (“Links” (page 38)); and drastically reformat widgets 
(“Widgets” (page 19)) and objects (Chapter 4).

The Format Bar
Running just below the Toolbar is the Format Bar (Figure 1-5). The options here change 
depending on what you have selected, but they generally offer some basic ways to modify 
whatever the selected object is. For example, if you select some text, you’ll have quick 
access for changing the paragraph or character styles (“Styles and the Styles Drawer” 
(page 34)); the font, text, and background colors; the font style (bold, italic, or underline); 
the alignment; the line spacing; the number of columns; and whether or not to style it 
as a list (see “Formatting Text” (page 27) in Chapter 3 for more on all of these things). If 
you click on a text box or graphic, the options change to customize the border and fill, 
opacity, and drop shadow; how to anchor the box; and how to wrap text around it (see 
Chapter 4 for more on formatting boxes and graphics).

Zoom
To get a bird’s-eye view of your layout, or to get up close and personal, you can use the 
zoom controls at the bottom of the editing window. There are a few options to choose 
from, including “Fit Width,” which zooms the pages in or out to exactly the width of a 
page, cropping the page vertically as needed, and “Fit Page,” which adjusts to fit the 
whole page both vertically and horizontally. If you choose one of the “Fit...” options, 
the page will automatically adjust to the window no matter how you resize it.

Navigation
Next to the zoom controls are two little arrows and a gear icon for navigating your book 
(Figure 1-6). The arrows will jump you between chapters, sections, or pages within 
sections of your book. Click the gear icon to choose what level you want to navigate 
between. You can also choose to jump between figures (“Figures” (page 55)), glossary 
terms (“Glossary” (page 9)), and bookmarks (“Links” (page 38)), and also between every 
occurrence of a particular paragraph or character style (“Styles and the Styles Draw
er” (page 34)).
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Figure 1-6. Use the zoom and navigation tools to see your pages in finer detail and to 
customize how you jump from section to section.

The Book Menu
All of your major book pieces are right at your fingertips here in the left portion of the 
screen. You’ve got four supplemental pieces—title page, Intro Media, Table of Contents, 
and Glossary—followed by either your page thumbnails or book outline, depending on 
which option you chose from the View button in the toolbar (see “View” (page 3)).

Book Title

Click the Book Title option in the Book menu and your book’s title page opens up in 
the main editing window. This is where you set some of the basic pieces of information 
about your book: Title, Edition Number, and Author. There are two ways to change 
your book title: with the Book Title already selected, click once again on the Book Title 
Book menu item, and the text there becomes editable—change it to whatever you want, 
and the title page will update to match. The opposite also works: edit the text on the 
title page, and the Book menu updates (see Figure 1-7).

If you go the second route, make sure you’re editing the field text, and not just 
appending extra text to it. Your visual clue is the blue outline that shows up 
around the words as you’re typing.

There’s only one way to update the author name and edition number: via the title page. 
You can see there are two more text fields on that page: edit the field at the very top to 
change the edition number, and edit the field at the bottom to change the author name.

Intro Media

You can add an image, audio file, or movie to introduce your book. If you choose to 
include this, the first time a reader opens your book in iBooks, she’ll see just that intro 
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Figure 1-7. There are two ways to change your book title: in the Book menu (top) or on 
the title page (bottom).

file on a black background. If you’ve chosen an audio file or movie, it’ll start playing 
automatically, but readers can stop it at any time by clicking the little x in the top left 
corner of the iBooks page. To add some intro media, click the Intro Media item in the 
Book menu, and then drag your image, audio, or movie file from Finder or the Media 
Browser onto the black background. You can move images or movies around on the 
screen, but audio files are stuck centered vertically. Author also only supports limited 
media file formats—see “Media” (page 60) for the full scoop.

Table of Contents

No need to worry about compiling a list of all the chapters and sections in your book
—iBooks Author automatically generates a table of contents for you as you write (see 
Figure 1-8). You can see the latest TOC by clicking “Table of Contents” (page 8) in the 
Book menu. iBooks pulls in the first image from each chapter in the TOC, but you can 
change that—just drag a new image from the Finder window onto the image box, and 
adjust it as described in “Images” (page 49). You can’t edit any of the auto-generated text 
on the TOC, but you can add new text boxes if you want—perhaps a short paragraph 
explaining what that chapter is about. Author adds a new TOC page for each Chapter 
in your book. (You can add more levels to your TOC—see “Document Inspector” (page 
11).) When you click on Table of Contents in the Book menu, Author will take you to 
the TOC page for whatever chapter you were last working on, but you can navigate to 
the TOC page for different chapters by clicking the little dots at the bottom of the editing 
window.
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Figure 1-8. A page from your book’s Table of Contents as it appears in Author (top) and 
in iBooks (bottom). Use the little dots at the bottom of the screen to switch to the TOC 
pages for different chapters.

Don’t worry about those little gray boxes at the bottom of each TOC page. When you 
export your book, Author fills those boxes with icons of the first page of each chapter 
and each section within a chapter, giving readers both a textual list and a visual way to 
navigate to those locations.

Glossary

iBooks Author has special tools just for educational books, such as the Glossary func
tion. You can turn any word in your book into a glossary term with just a few clicks. 
Double-click to select a word, then right-click or Command-click, and choose “Create 
New Glossary Term from Selection” from the content menu (Figure 1-9). The word 
turns bold, which is your indication that it’s been added to your Book’s glossary.

You can also add new glossary terms from the Glossary Toolbar (see Figure 1-10), by 
either typing the term in the New Glossary Term box and clicking Add Term, or by 

Editing Window | 9



Figure 1-9.   Right-click or control-click a word in your book and choose “Create New 
Glossary Term from Selection” to create a new glossary term. The word turns bold to show 
that it’s been added to the Glossary. Click the term again to jump straight to the Glossary 
and add a definition.

double-clicking to select a word in the text and, instead of right-clicking on the word, 
clicking the Add Term button. Note that if you add a new term without selecting a word 
in the text first, that term won’t link to any locations in the book until you set one or 
more index locations (see below).

Unfortunately, Author doesn’t take the trouble to define the term, too—that’s up to you 
(although once your book is finished and loaded into iBooks, readers have the choice 
of viewing the dictionary definition for a glossary term or the definition you add in the 
Glossary). Click on the word to jump straight to the Glossary (or click the Glossary item 
in the Book menu), where you can add a definition and see your full list of Glossary 
terms.

You can link multiple terms together to give readers more guidance if they need it. Just 
drag other terms from your Glossary into the Related Terms section; to unlink a term, 
drag it out of the Related Terms section and it disappears in a puff of smoke.

Adding Related Terms doesn’t work both ways. For example, if you drag the 
word “coffee” into the Related Terms section of the word “beverage,” “coffee” 
will be added there, but “beverage” will not be added as a Related Term for 
“coffee.”
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Figure 1-10. Use the Glossary Toolbar to quickly add new glossary terms or add new index 
locations for existing terms.

The Index section tells you where you can find the term in your book. It only automat
ically links to the place in the book where you first chose to turn the word into a glossary 
term, but you can add as many index entries to other locations as you want. To do so, 
make sure you have the Glossary Toolbar displayed (from the View button in the Tool
bar), then select the word or location in your text that you want to add a link to, choose 
the glossary term from the “Index link for” drop-down menu, and click Add Link. You 
can use the “Find Term” button from the Glossary to search the book for every occur
rence of a glossary term (note that this is only an option in Author; readers have to 
search the book themselves), and add Index Links to any or all of the found results. This 
opens up Apple’s standard Find/Replace dialog box, auto-filled with your glossary term, 
and jumps you to the first occurrence of that word in your text. Every word that you 
turn into a glossary index link becomes a clickable link to that glossary definition.

You can add or delete glossary terms in the Glossary as well, by clicking the + and – 
buttons below the search bar. Author won’t let you create multiple glossary terms for 
the same word; if you right-click on another occurrence of a word that already has a 
Glossary definition, the “Create New Glossary Term from Selection” option is grayed 
out. And if you try to add the duplicate term via the Glossary, Author automatically 
appends the word “duplicate” to the end.

Page Thumbnails and Book Outline

Below the Book menu, Author lists the pages in your book either as thumbnail icons or 
in outline view, depending on the option you chose from the View button in the Toolbar. 
Click any thumbnail or list item to open that page in the editing window; Author also 
outlines all the sections in that chapter with a yellow box, letting you know where you 
are in your book.

Document Inspector
Your first option when you open the Inspector is the Document Inspector, where you’ll 
find some fields to add information about your book and set some basics. In the first 
boxes in the Inspector, you can note the author name and the book title, add keywords 
about the book, and insert any special comments about it.
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The next section gives you some basic document data: word and character counts, 
number of pages and images in the book, and so on. You can get info for the entire 
document or just a selection.

Figure 1-11. Add basic book details and customize the Table of Contents in the Document 
Inspector.
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Turn on “Disable portrait orientation” if you don’t want readers to be able to read your 
book in portrait mode on their iPads. There’s an argument to be made for both leaving 
this off and turning it on: On the one hand, you want to give your readers control over 
their reading experience, but on the other hand, why bother creating a complex layout 
in iBooks Author just to let readers ignore all your work by reading in portrait mode?

Turn off Hyphenate to keep your words from breaking across lines, and turn off “Use 
ligatures” to keep Author from adding ligature characters where it normally would. 
Ligatures are letters that run together to form one character. Some of the usual suspects 
are ff, fl, and fi. Turning off this checkbox keeps each letter separate, instead of com
bining them into one.

The last option on this tab is “Require Password to Open.” You can password-protect 
your file using this checkbox; just make sure you share the password with anyone else 
who needs to open the file.

Over on the TOC tab, you can customize your book’s Table of Contents by adding or 
removing section types and paragraph style types (Figure 1-11). By default, the TOC 
will include Chapters, Sections, and Headings. You can have it include text tagged with 
other paragraph styles by clicking the + button and choosing the style you want. For 
example, you can list every widget in the TOC by adding the Figure Title paragraph 
style to the list.

Only chapters and sections appear in the TOC when you or your readers are in 
landscape mode; other paragraph styles appear when you switch to portrait ori
entation.

Now that you know your way around, it’s time to start adding pages and building your 
book.
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CHAPTER 2

Book Building Basics

In the chapters that follow, you’ll learn how to build the components and pages of your 
book. You’ll see how to employ the tools and widgets introduced in Chapter 1 to create 
new sections and chapters, style text, lay out pages, and insert and manipulate images. 
Then, you’ll move on to the fun interactive stuff you can do with iBooks Author built-
in widgets.

Before you get into the nitty-gritty of creating ebooks, however, you need to reconsider 
your notion of the “page.” In this chapter, you’ll see how, with the iBooks Author pub
lishing platform, Apple has re-envisioned traditional page layouts and book design to 
come up with something new altogether, which they are calling Multi-Touch Books.

What Is a Page?
Trying to learn about differences between ebook formats can be a dizzying experience. 
Each device accepts some certain subset of the available formats. The Kindle accepts 
Mobi and PDF, but not EPUB. iBooks accepts EPUB and PDF, but not Mobi. You can 
probably think of more examples. So what are the differences among these types, and 
why should anyone care?

Page Layout, Fixed
Most fundamentally, there are two kinds of ebook formats—those that use a fixed page 
layout and those that use a fluid page layout. PDF is the classic example of a fixed page 
layout. No matter which device you read a PDF on, the text, images, and all of the other 
parts of the page will always look the same. The fonts will never change, and the page 
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numbers are eternal. Traditional publishing tools such as InDesign, FrameMaker, and 
Quark excel at providing content creators with a means to produce fixed page layouts. 
These tools output PDF, which in turn can be sold as an ebook or printed as a traditional 
book.

Page Layout, Fluid
Ebook formats that are fluid, on the other hand, reflow to fit the container in which the 
text is read. EPUB and Mobipocket are examples of fluid formats. You may have ex
perienced a fluid format if you’ve ever read the same ebook on your phone, tablet, and 
computer monitor. In each case, the reading system reflows the text to fill the screen 
on which you are reading. Additionally, each reading system may have its own set of 
fonts and its own page numbering system. As the ebook market has grown, publishers 
have struggled to find new tools to create fluid layouts while continuing to produce 
fixed layout formats.

Page Layout, Something in Between
The iBooks Author format (.ibooks) produces pages that are somewhere in the middle 
between fixed and fluid. This distinction makes it the first format of its kind, and by 
extension, the iBooks Author application is the first tool of its kind. Never before have 
ebook makers had a tool that allows them to simultaneously create pages that are both 
fixed and fluid (but also fluid in a new way, as you’ll see in the next section). A clear 
understanding of how pages flow (or don’t flow) in ebooks created in iBooks Author is 
crucial before you start building your own pages.

Pages Based on iPad Orientation
iBooks Author allows you to create pages that adapt to how the reader is holding the 
iPad. The reader can hold an iPad in only two ways: horizontally (landscape) and ver
tically (portrait). The following is an explanation of how content works in each orien
tation.

Landscape Versus Portrait Orientation
If the reader is holding the iPad sideways (i.e., landscape), the page layout is akin to the 
kind of fixed page layout that we see in traditional books. Figure 2-1 shows an example 
of a landscape page.

A reader navigates these landscape pages by swiping horizontally. Swiping to the left 
brings up the next page. Note the page number in Figure 2-1. Also, note the captions 
beneath the Figure and Gallery. Now look at portrait orientation and observe how those 
things change.
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Figure 2-1. A landscape page layout from Life on Earth: An Introduction is a familiar 
fixed page layout.

If that same reader turns the iPad vertically, the ebook switches to a portrait orientation 
and both the presentation and method of navigation change. Figure 2-2 shows the same 
part of the book in portrait orientation.

In portrait orientation, the presentation of the content is dramatically different from 
the landscape presentation. Here are some differences worth considering:
Fixed versus fluid layout

Instead of a fixed page layout, the reader is presented with a long, scrolling text that 
contains the entirety of the chapter, which is one method to present content in a 
fluid way. The reader navigates the text by swiping vertically, as opposed to hori
zontally.

Page numbering
As you can see, this portrait view has its own page-numbering scheme (page 14 
versus page 16).

Content differences
Even more interesting, though, is how the presentation of the content changes. 
Note, for example, how in portrait orientation (Figure 2-2) you are unable to see 
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Figure 2-2. The same part of the book shown in Figure 2-1, but in portrait orientation.

the longer captions for the Gallery and Figure, as you can in landscape orientation 
(Figure 2-1). The captions are still available to the reader in portrait mode: the 
reader just needs to click on an image to bring up a full-screen version, which 
includes the full caption that we see in the landscape version of the page.
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Figure 2-3. A full-screen view of an image in portrait and landscape mode shows that they 
have the same content but a different orientation.

Image orientation
Another thing to keep in mind is that full-screen versions of these images also have 
their own landscape and portrait presentations, although the difference between 
these two presentations is much less dramatic than we saw with the page layouts 
(Figure 2-3).

This full-screen pop-up view is available to readers in both landscape and portrait ori
entations and extends beyond just images. Tables, charts, videos, and widgets all have 
full-screen pop-up views. Widgets are of particular interest in the larger context of how 
orientation affects interactivity, as we’ll see in the next section.

Orientation and Interactivity
Before you can begin building your book in iBooks Author, you need to have an un
derstanding of how page orientation affects how a page behaves. That behavior, in turn, 
affects how a reader interacts with the page in any given page orientation. One of the 
key ways that a reader can interact with content on the page is via a widget.

Widgets

The level of interactivity available to the reader via widgets changes based on page 
orientation. You’ll learn more about how to add and edit widgets in your book later in 
Chapter 4. For now, note that widgets can be interacted with directly on the page in 
landscape view; in portrait view, the reader must use the full-screen pop-up version of 
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Figure 2-4.   The Gallery widget enables interactivity directly on the page, but only in 
landscape view.

the widget. For example, the image on the left in Figure 2-1 is actually a Gallery widget, 
which allows you to insert multiple images and captions in the same image box. (Think 
of it as a slideshow on the page—see “Gallery” (page 59) in Chapter 4 for more details.) 
A reader can swipe horizontally on the widget to navigate to the different images. 
Figure 2-4 shows the same page again, but with the widget displaying a different image 
in the gallery.

The behavior demonstrated in Figure 2-4 is typical of widgets in general. If you were to 
insert a video, for example, the reader would be able to play that video directly on that 
page in landscape view, but in portrait view, the reader would have to view the movie 
in a full-screen pop-up window.

Table of Contents

You’ve seen how orientation affects interactivity in basic page layouts and widgets. You 
should also consider how orientation and interactivity work in other parts of the book. 
For example, iBooks Author allows you to create a table of contents that looks and acts 
strikingly different in the two orientations. Figure 2-5 shows the table of contents from 
Physics: Principles and Problems (McGraw-Hill) in portrait orientation.
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Figure 2-5. The portrait view of the table of contents is functional but unremarkable.

This portrait view of the table of contents allows the user to click on arrows to navigate 
to different sections of the book, which is the kind of thing we see in standard ebook 
reading systems. The landscape view is something different altogether and allows you, 
the content creator, to assemble a table of contents that represents the next generation 
of book navigation, as shown in Figure 2-6. (See “Table of Contents” (page 8) in Chap
ter 1 for more about customizing your TOC.)

The landscape version of the table of contents shown in Figure 2-6 gives the reader no 
fewer than four different ways of navigating the book:

• A full-page horizontal swipe, allowing the reader to scroll to the next chapter, each 
of which has a full-page navigational spread in the table of contents, similar to this 
one

• A vertical swipe in the smaller window below the chapter title, allowing the reader 
to navigate to a section within the chapter

• A horizontal swipe of the preview pages, allowing the reader to jump to a particular 
page

• A clickable row of dots along the bottom panel, allowing the reader to navigate to 
different parts of the book
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Figure 2-6. There are multiple ways to navigate a book in the twenty-first century.

That such complex and rich navigational possibilities are available to the reader simply 
by turning the iPad to the side is remarkable because it gives you, as the book maker, an 
entirely new way to help your reader discover and enjoy your content.

Assembling the Pages
Now that you’ve got an idea about how “pages” work in iBooks Author, you can start 
to think about how you can use it to assemble your own pages. If you’ve had experience 
with traditional publishing tools, the landscape orientation page layout described in the 
previous sections probably seems familiar to you. Just as you would with a traditional 
page layout program, you use the iBooks Author tool to lay out the various components 
of any given page, and that page remains fixed. Sure, compared with something like 
InDesign, the Author interface looks a little bit different and the interactive widgets 
throw in something else to consider, but the basic concept is the same. You’ve got a 
button for adding text boxes, another for moving images around, another to change 
fonts, and so on. In this way, you might think of iBooks Author as InDesign for the 
iPad.
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Figure 2-7. It’s not a coincidence that the Orientation button has a prominent place in 
the iBooks Author interface.

But if you’ve read this far, you know that things are more complicated than that because 
the portrait view has its own set of considerations. iBooks Author helps you manage 
the design and layout of the two orientations with the Orientation button, which is 
pretty hard to miss (Figure 2-7).

When you first use that Orientation button, you’ll notice that, once you’ve laid out a 
page in landscape view, you’ll get the portrait layout “for free.” In other words, iBooks 
Author will flow your text into a scrollable container and set off everything else (images, 
widgets, and so on) as small, clickable thumbnails in the left margin. In fact, just as the 
page layouts in landscape view are incredibly flexible, the portrait view is very rigid. 
When you are building your pages, you’ll find that there is much less for you to do and 
consider for portrait view beyond potentially resizing and moving (but only vertically) 
the thumbnails.

Regardless of the way portrait view tends to take care of itself, as you make your way 
through the sections that follow, you’ll want to make the Orientation button your best 
friend. As you build your pages and present your content, keep in mind that any given 
reader may be reading the content in either portrait or landscape or both. For every 
reader who takes the time to enjoy your meticulously laid out fixed landscape page, 
there is another reader who just wants to scroll through the content in portrait and read 
it as quickly as possible. When you build books in iBooks Author, be sure to keep in 
mind both types of reader.
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CHAPTER 3

Text

The first thing you’re probably going to want to add to your book is some text. Author 
is a powerful text editor (a lot like Apple’s Pages) with the full gamut of text formatting 
tools. You can click the placeholder text and type away, or you can import your content 
from a Word or Pages file.

Placeholder Text
Whenever you add new pages, Author prefills them with placeholder text, to give you 
a sense of how the pages will look when you’re done. Click once on any stretch of 
placeholder text, and Author selects the whole thing for you to overwrite with your own 
masterpiece.

If you start typing a sentence and realize you’re not actually ready to write that part yet, 
you can retag it as placeholder text for easy editing later on. Select the string of text you 
want to turn into a placeholder, and go to Format → Advanced → Define as Placeholder 
Text. Author won’t let you tag fields (see “Text Variables” (page 71)) or linked text as 
placeholders, however, including any sentence or passage that has a glossary term or 
index link in it.

Importing a Text File
Choose Insert → Chapter from Pages or Word document... to insert a document you’ve 
already written into your Author project. When you choose the file you want to import, 
Author asks you what kind of layout you want it to have; choose one of the options, and 
Author inserts a new section using the layout you chose, filled with your document. 
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Author will use the document filename as the title of the chapter or section, which you’ll 
likely need to change. You can do that in either the Book menu (by clicking the chapter 
title next to the page thumbnail or outline item, pausing, and then clicking again) or in 
the text itself (Figure 3-1).

Figure 3-1. There are two places you can change a chapter title: in the Book menu or on 
the chapter title page.

Author is sometimes a bit finicky about letting you update the chapter title from 
the first page of the chapter. You may find that when you select all of the place
holder text in the field (see “Text Variables” (page 71)) and type over it the field 
box gets deleted, which means it’s no longer linked to the page thumbnail and 
the TOC. If you noticed right away, just undo and either type your new title in 
the middle of the placeholder text and then delete the bits that you don’t want 
letter by letter, or change the title via the page thumbnail label. If it’s too late for 
that, just go to another chapter and copy the entire Chapter Title field (by triple-
clicking and hitting command-C), paste it in the correct place, and then try to 
edit the Chapter Title text again a bit more carefully.

If you added your file as a new chapter, Author leaves the introductory paragraph filled 
with placeholder text, for you to add a prelude or subtitle to your chapter. If you already 
had one written in your text file, just cut and paste it into the right place.

Another option Author gives you when you import text files is to “Preserve document 
paragraph styles on import.” If you’ve been using Word’s or Pages’ paragraph styles, 
turning this checkbox on copies those style names into your book file, along with their 
definitions. For example, if you formatted your body paragraphs in a 16-point, purple, 
Comic Sans paragraph style called “Normal,” Author will import that paragraph style 
and do its best to recreate that same styling in your book. If for some reason it can’t 
duplicate part of the style, it’ll open a warning dialog box when the file imports, telling 
you what part it failed to recreate (usually fonts).
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If you aren’t sure what paragraph styles are, see “Paragraph Styles” (page 36).

Embedded image files in your text file are no problem—Author imports them along 
with everything else, and lets you edit them the same as any other image (see “Im
ages” (page 49)).

Formatting Text
Author comes fully equipped with the standard text formatting tools (Figure 3-2).

Figure 3-2. The text Format Bar has all the tools you’d expect for formatting text.

In the Format Bar you’ve got the basics:
Styles Drawer icon

This icon toggles the Styles Drawer open and closed (more about the Style Drawer 
in “Styles and the Styles Drawer” (page 34)).

Paragraph icon
Lists all the paragraph styles in your document for you to choose from (see “Para
graph Styles” (page 36), below).

“a” icon
Lists all the character styles in your document (see “Character Styles” (page 37), 
below).

You don’t need to select an entire word to apply the next few options. Just click 
within any word, and when you choose a new value, the whole word will change. 
However, you want to change more than a word, or if you want to change an 
entire paragraph, you’ll need to select it.

Font drop-down
Select some text and choose a font. You get a preview of each font in the drop-down 
menu, so you can make an informed choice. Don’t go too crazy with the fonts 
though; it’s generally good practice to limit yourself to one serif font family and 
one sans serif within a project (but you can use as many faces within the family as 
you like).

Typeface drop-down
Here you choose the specific font face you want to use—regular, italic, bold, etc.
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Font Family? Face? Serif?
Fonts are described in a few ways. First, all fonts are divided into families. A font family 
is a set of related fonts that share lots of the same characteristics, but differ in terms of 
style, weight, and so on. Each font within a font family is called a font face. Helvetica Italic, 
Helvetica Bold, and Helvetica Condensed are all different font faces within the Helvetica 
family.

Fonts are also classified as serif or sans serif. A serif is that little foot that sticks off some 
of the letters in a font family. Serif fonts are fonts that have that little foot; sans serifs do 
not (sans is French for “without,” i.e., “without serif”). Times, for example, is a serif font, 
and Helvetica is a sans serif.

Font size
Choose a size for your text selection. In printed books, anything from 9 to 11 points 
is usually good for body text; however, that would be far too small for a fixed layout 
ebook like this. Author suggests 16 points as the standard body text size. Play around 
with a few different sizes and preview them on your iPad to find one that works for 
you.

Text color
Choose a color for your text. Darker colors are usually best on a light background. 
If you’ve got a very dark background, you can probably get away with white or light-
colored text, but be careful not to strain your readers’ eyes too much.

Text background color
You can give your selected text a background color if you like. This is an easy way 
to highlight key terms or phrases if the glossary bolding isn’t enough, but again, 
use this judiciously.

Bold, Italic, and Underline
The usual buttons to quickly change the typeface.

Paragraph alignment: Left, Center, Right, Justify
For body text, it’s generally best to stick with left-aligned or justified text. Right-
aligned text is okay for short passages, like figure captions, titles, or callouts, but in 
most Latin-based languages (like English) it’s hard to read long stretches of right-
aligned text. Centered text is good for quotes and other text you want to draw 
attention to, but again, it isn’t usually appropriate for long stretches.

Line spacing
This option adjusts the space between the lines in a paragraph. You don’t need to 
select an entire paragraph to change the line spacing. Just click anywhere within 
the paragraph and choose a new value from the line spacing drop-down, and your 
paragraph will expand or shrink accordingly.
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Columns
Determines how many columns to split the paragraph(s) into. You can choose from 
one to four columns.

List style
Here you can turn your paragraph into a numbered or bulleted list. You have a few 
different list styles to choose from, or you can make up your own by choosing Show 
More. From the Show More menu, in addition to numbered and bulleted lists, you 
can create lists that are marked by images, and you can define how far to indent the 
list, how far up or down to align the bullet character, and how big it should be. Once 
you’ve got your list looking the way you want, you can turn it into a paragraph style 
to use throughout your book: right-click on the styled paragraph and choose “Cre
ate Paragraph Style from Selection.”

If you need to insert a glyph, like a star, apple symbol, or ☺, open the Font window 
by clicking the Fonts button in the Toolbar, click the gear icon in the bottom 
right corner, and choose Characters... from the flyout menu. All the glyphs in 
the font you had selected are neatly organized here by type.

Text Inspector
The Text Inspector (Figure 3-3) puts all your text formatting tools at your fingerprints. 
To get to it, open the Inspector from the Toolbar, and go to the fourth-from-left tab 
(the big T). There are four tabs within the Text Inspector. The one thing you can’t change 
through the Text Inspector is font family and face—you’ll have to set those in the Format 
Bar.

Text
These are some of the usual paragraph and text formatting options. At the top, you can 
change the color and alignment of your selected text, and also change the vertical align
ment within the text box. To change the color, click the color swatch, and choose wisely. 
If the swatch was black, the color wheel Author gives you will at first seem to offer you 
only black as an option; drag the slider on the right up to reveal the full spectrum of 
colors.

The spacing sliders let you adjust the amount of white space horizontally between the 
individual letters in a paragraph, and vertically between lines. You can also add space 
above or below a paragraph, and with Inset Margin you can add padding around the 
edges of a text box, to push your text away from the border.
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Figure 3-3. The four tabs of the Text Inspector put almost all your text formatting tools 
in one place.

List
If you want to turn your text into a list, or if it’s already a list and you want to change 
the way it looks, head to the List tab. Your first choice is Indent Level, which determines 
how far to indent the list from the left edge of the page. Each successive level is meant 
for that level of nested list—for example, choosing 3 here would mean a list within a list 
within a list. Author has some standard indent sizes, but you can adjust them with the 
next options.

Next you choose what kind of list you want—bulleted or numbered—and how to style 
the list marker. The option you choose determines what you’ll see next. If you choose 
Text Bullets, you can choose what icon to use as the list marker, and what color to make 
it. If you choose Image Bullets, you can choose from a list of standard images for your 
list marker. If that’s not enough, choose Custom Image to choose an image file from 
your computer to use. No matter which bullet style you choose, you can change how 
big the bullet is compared to the text (Size), how far up or down to align it next to the 
paragraph (Align), and whether to scale the bullet image as you resize your text. If you 
turn this checkbox off, the bullet will stay exactly the same size no matter how big or 
small your text is; turning it on will maintain the same proportion between bullet and 
text that you see now.

If you go for a numbered list, you only get a few choices. You can choose either plain 
or tiered numbers (Figure 3-4). Tiered numbers reference how far deep the list item is 
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Figure 3-4. Regular numbers (left) versus tiered numbers (right).

nested; they’re great for referring to sections. For either type of numbering, you can still 
change the number style: regular, uppercase Roman numerals, lowercase Roman nu
merals, uppercase letters, and lowercase letters. You can also choose how to separate 
the number from the text (period, right parenthesis, or double parentheses).

Once you’ve picked your number style, choose whether you want the number to con
tinue from wherever the last numbered list left off or to start the numbering over at any 
number you choose. The most common value here is probably going to be “1.”

For both numbered and bulleted lists, you can adjust the amount of indent. Use the 
Bullet/Number Indent box to indent the whole paragraph more or less; use Text Indent 
to add more space between the list marker and the text.

Tabs
The first section here is actually your paragraph indent settings. You can indent just the 
first line to get a classic look, and also indent paragraphs on both the left and right sides.

Next you get into the actual tab settings. Tab stops are how far you jump when you hit 
the tab key. The default is 36 points, but you can make this more or less. There are four 
standard kinds of tab stops: left, center, right, and decimal (Figure 3-5). Here’s how each 
one works:
Left

These are the most common. Press the tab key to jump ahead, and then any text 
you add grows to the right, just like normal.

Center
Text grows evenly from both sides of the tab stop.
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Figure 3-5. Here’s a visual comparison of the different kinds of tabs: left, right, center, and 
decimal. All four have the same tab stop position, but have different alignments.

Figure 3-6. Quickly add tabs by clicking the ruler. Control click to change the tab align
ment.

Right
Text grows to the left of the tab stop, as if the paragraph were right-aligned.

Decimal
Text aligns on a particular character. Usually this is used in accounting or with lists 
of numbers, to keep the numbers aligned on the decimal point. You can choose a 
different character to align to in the “Decimal Tab Character” box.

You can add your own custom tab stops for each paragraph. Press the + button at the 
bottom of the Tab Stops section, and a new tab stop gets added to your list. Click the 
number in the list to change the location of the tab stop, and click the radio button for 
the type of tab you want.

Turn on your rulers (View → Show Rulers) to get a more visual way to set tab stops 
(Figure 3-6). Click in the paragraph you want to add a tab stop for, and then just click 
on the ruler wherever you want to add the tab stop. Author chooses a left tab by default; 
right-click or control-click on the new tab to change to a different style. To move a tab, 
grab it on the ruler and drag it wherever you want. To delete a tab, drag it off the ruler 
and it disappears in a puff of smoke.
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You can also adjust your paragraph indents via the ruler; drag the two down-
pointing arrows to add more space on either side.

You can add a leader to any of your tabs, to fill the space the tab jumps over with a 
character (usually a row of dots). You see this a lot in tables of contents or playbills. 
Select the tab you want to add a leader to, and choose the leader style from the drop-
down.

Setting your own tab stops is a real pro move, but most people will probably find that 
the defaults are fine.

More
Here’s where you can get really fancy. Add a custom border to a particular paragraph, 
a background to just a few selected characters or to the paragraph as a whole, and a lot 
more (see Figure 3-7). Here are all your options:
Border & Rules

Add a border to any or all sides of just one paragraph within a text box. Once you 
choose a line style from the drop-down list, the other options become active. Set 
the line color and weight, and pick which edge (top, bottom, both, or all) you want 
the border to run along. Adjust the offset to push the border further from or closer 
to the paragraph text (you can even go into negative numbers, which will make the 
border overlap the text).

Background Fills
Select a few characters or a word and turn on Character and choose a swatch to add 
a background color to just that word (for example, to create a highlighter effect). 
To add a background color to an entire paragraph, turn on the Paragraph checkbox.

Following Paragraph Style
You can dictate what kind of paragraph to insert after your current paragraph. 
Choose any of your existing paragraph styles from the drop-down list. If the style 
you want doesn’t exist, you’ll need to create it first (see “Styles and the Styles Draw
er” (page 34)).

Pagination & Break
These checkboxes apply to the whole paragraph and tell it how to act when it breaks 
across multiple pages. “Keep lines together” will keep the whole paragraph together 
on one page. If any of the lines don’t fit on a page, the whole paragraph will jump 
to the next page. “Keep with following paragraph” does just what it says—keeps 
two paragraphs together on the same page; this is great for definition lists or to keep 
section headers from appearing alone at the end of a page. “Paragraph starts on a 
new page” will force your paragraph to start on a new page, pushing all the text that 
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follows along with it. This is often used for section headers. “Prevent widow & 
orphan lines” is on by default, and you probably want to keep it on. It prevents 
individual words or lines of text from getting stranded at the top or bottom of a 
page. You can choose any, all, or none of these options.

Language
Tells Author what language the selection or paragraph is written in. This isn’t a 
translator—it affects how Author checks your spelling. You can select just a few 
words and change the language, or you can change it for the whole paragraph by 
making sure nothing is selected and choosing the language from the drop-down 
list.

Remove hyphens from paragraph
Keeps words from breaking across lines. If this is turned on, words can split across 
lines and Author will add a hyphen. Turned off, if a word can’t fit in its entirety at 
the end of a line, the whole thing will drop to the next line.

Remove ligatures
Ligatures are letters that run together to form one character. Some of the usual 
suspects are ff, fl, and fi. Turning on this checkbox keeps each letter separate, instead 
of combining them into one.

Baseline Shift
Adjusts text up or down; this is best used for individual words or phrases. Select 
some text, and use the up and down arrows to move it vertically, creating a super
script or subscript look. If you want to shift whole paragraphs, you should probably 
use the options on the Text tab of the Text Inspector.

Styles and the Styles Drawer
Paragraph and character styles have been around for a while, and they are built into 
almost every robust text editor or layout program these days. They allow you to create 
a consistent look for paragraphs or text spans of the same type to use throughout your 
document. All of Author’s templates come with a suite of paragraph and character styles 
to complement the template design, but you’re free to edit them or even to create your 
own styles as needed.

Styles are so important that Author gives you all kinds of ways to get to them. You can 
choose them as needed from the drop-down lists in the Format Bar, but to have them 
at your fingertips at all times, your best bet is to open the Styles Drawer (Figure 3-8). 
To do so, click the blue Styles Drawer button at the far left of the Format Bar, go to View 
→ Show Styles Drawer, or click the View button in the Toolbar and choose Show Styles 
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Figure 3-7. This ugly little paragraph uses almost all the options in the More tab: top and 
bottom border, paragraph background (notice that the background also fills any space 
above or below that you set on the Text tab, but the borders don’t), character background 
(the word “Preferences”), “Keep lines together,” and the word “picas” shifted above the 
baseline.

Drawer. This opens an extra panel on either the left or right of your editing window 
(depending on which side has more open space on your monitor), listing all the styles 
in your template, plus any extras that you imported with text files (see “Importing a 
Text File” (page 25)) or added yourself.

Select some text and open up the Styles Drawer—you should see three style names 
highlighted in blue. These are the different styles applied to the text you selected, one 
for the paragraph style, one for the character style, and one for the list style. (If there 
isn’t a style applied for any of these three categories, the word None will be highlighted.)
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Figure 3-8. The Styles Drawer for this paragraph. You can see this paragraph uses the 
Body style (but it has some overrides, as evidenced by the red arrow), no character style, 
and Bullet list style.

Paragraph Styles
Paragraph styles affect the formatting of an entire paragraph—things like font family 
and style, line height, alignment, number of columns, and so on (but you can include 
as much or as little of that stuff in the style definition as you want). To apply a paragraph 
style, click inside any paragraph of text, and then click on the paragraph style name in 
the Styles Drawer or choose it from the drop-down list in the Format Bar.
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Figure 3-9. The context menu that pops up when you click the arrow next to a style name 
gives you a few ways to apply or reapply the style to your selection. Choose Redefine Style 
from Selection if you want the style to incorporate any custom formatting you added to 
the paragraph.

To edit an existing style definition, adjust the formatting as you like via the Text In
spector or the Format Bar, and then in the Styles Drawer click the little arrow next to 
the style name, and choose “Redefine Style from Selection” (Figure 3-9). Author will 
update all the other paragraphs in your book that use that style to match your new 
formatting.

If you apply a style to a selection, and then manually change the formatting of that 
selection outside of the style definition, the little arrow next to the style name in the 
Styles Drawer turns red. This is your clue that the text has style overrides. If you want 
to get rid of the overrides, click the arrow and choose “Revert to Defined Style” or just 
click the style name again to reapply it.

To see every place where a particular paragraph (or character) style is used, click the 
gear icon next to the page navigation buttons at the bottom of the window (“Naviga
tion” (page 6)), choose the style name from the list, and then click the buttons to navigate 
between each usage of that style.

You can hide all the other kinds of styles in the Styles Drawer, but you can’t hide para
graph styles.

Character Styles
Character styles work a lot like paragraph styles, except they’re only applied to words 
or phrases of text. You also have fewer formatting options—none of the formatting that 
applies to whole paragraphs will work here (for example, line height, paragraph align
ment, and so on). Character styles are best for changing the style or weight of text, like 
making it bold or adding an underline.
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Wondering why you’d want to use character styles instead of the bold, italic, and 
underline buttons? With character styles you can change the way italic text looks 
throughout your entire book in one stroke; if you wanted to accomplish the same 
thing manually, you’ve have to hunt for every italic word and reapply the for
matting.

To apply a character style, select the text you want to style, and then click the character 
style name in the Styles Drawer or choose it from the drop-down list in the Format Bar. 
To hide character styles, click the little “a” icon in the lower-right corner of the Styles 
Drawer.

List Styles
List styles work the same as paragraph and character styles, except they determine the 
way your lists will look—bullet or number style, indenting, and the like. To hide list 
styles, click the little list icon in the lower-right corner of the Styles Drawer.

Hot Keys
You can assign Hot Keys to the styles you use most, so that you can apply a style 
throughout your book with just one keystroke (instead of having to select it from the 
Styles Drawer every time). To do so, in the Styles Drawer, click the little down arrow 
next to the style name, click Hot Key, and then choose one of the keys to assign to that 
style. You have eight options—F1 through F8—which means you can only assign Hot 
Keys to eight styles. If you’ve already assigned a specific Hot Key to another style, that 
option will appear grayed out in the Hot Key drop-down list. Once you’ve assigned a 
Hot Key to a specific style, all you need to do is select some text and hit that Hot Key to 
apply the style to your text.

If your “F” keys share space with other commands, like turning the brightness 
up or down (as they do on most Mac keyboards), you’ll need to hold down the 
function (fn) key while you press the “F” key you want.

To remove a Hot Key from a style, click the arrow next to the style name and choose 
Hot Key → None.

Links
Cross-references are an integral part of most reference books; they are links or pointers 
to related sections of the text that give readers more guidance (this book, for example, 
is full of them). Unfortunately, inserting cross-references isn’t quite one-click in Author, 
but it is possible. First you need to mark the section that you want to reference, by 
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Figure 3-10. The first step in creating a cross-reference is to add a bookmark. This is a 
bookmark for the Tip paragraph on this page. You can also add bookmarks via the Link 
Inspector, by clicking in the text you want to bookmark and then clicking the + button.

inserting a bookmark (Figure 3-10). Click at the beginning of the section or passage, 
and choose Insert → Bookmark. Author opens the Link dialog box and creates your 
new bookmark, called “Bookmark.” Click the word “Bookmark” and change the name 
to whatever you like, but choose something unique so you don’t get confused later on.

Next, select the text that you want to link to that section, then choose Insert → Hyper
link → Bookmark (Figure 3-11 ). Author opens the Link dialog again; choose your 
bookmark name from the drop-down, and you’re done.
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Figure 3-11. Step two in creating a cross-reference is adding a hyperlink that points to the 
bookmark you created in Figure 3-10. The text you selected gets the Hyperlink character 
style applied to it, but you can change that. It also gets a blue border, which tells you that 
the text is a field (see “Text Variables” (page 71)).

To remove a cross-reference, click to select the hyperlinked word or phrase, and then 
open the Link dialog (if it’s not still open, just click the Inspector button in the Toolbar 
to get back to it) and uncheck the “Enable as a hyperlink” box. You may also need to 
remove the extra character style that Author automatically adds to links, but that’s easy: 
select the word or phrase, and then in the Character Styles list, choose “None.”

Author does make it easier to add links to labeled objects, like Galleries (see “Gallery” 
(page 59)), Media boxes (see “Media” (page 60)), and Figures (see “Figures” (page 55)). 
Select the text that you want to turn into a link, and choose Insert → Hyperlink → Figure 
Reference. The Link Inspector opens, giving you a list of all the labeled objects in your 
book to choose from. Click the one you want to link to, and your clickable link is all set.
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Figure 3-12. Get more control over your text flow with column and page breaks. Author 
adds a blue line and marker showing you where you’ve inserted the break. (Go to View 
→ Show Invisibles if you don’t see anything special.)

Text Boxes
Author fills up all the pages you insert with an array of images and text, but you can 
replace it all with whatever you want. If you want to add text where there used to be an 
image (or over some blank white space), you’ll need to insert a text box first. All the text 
in your book is contained within text boxes that you can drag around and resize however 
you want. To add a new one, click Text Box in the Toolbar; Author slaps a new text box 
right in the middle of your page, filled with the helpful guide “Type to enter text.” Drag 
this box to the correct location, and then click inside it and start adding your text.

You can adjust the look of the text box by adding a stroke, drop shadow, and other 
object options. Skip ahead to Chapter 4 for the details, and check out “Shapes” (page 56) 
to learn more about fills and backgrounds.

Column and Page Breaks
Use column breaks and page breaks to control how much text to keep in a text box or 
on your page (Figure 3-12). Click in the text where you want it to break, and go to 
Insert → Column Break or Page Break. You can even add a column break at the begin
ning of a multicolumn text box to skip the first column entirely. To delete a column or 
page break, click in the text immediately following the break, and hit the Delete key.

Sidebars
Sidebars are passages of text that are set apart from the main text flow, usually in a 
special box. Apple went ahead and designed sidebar boxes to match each of the canned 
templates, but you can create your own, too.

Author doesn’t give you a toolbox to pull design elements like sidebars from, but it does 
add them to certain pages in the template. To insert a new Author-designed sidebar, 
insert a new page that includes the sidebar, or copy a sidebar from another location in 
your book and paste it in the correct place. You can also edit the formatting of the canned 
sidebars, if Author got everything except for a few minor details right.
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Figure 3-13. Here’s an example of a custom sidebar. This used to be a static text box, but 
it’s been turned into a widget by turning on the “Title” checkbox in the Widget Inspector, 
and giving it a Label of “None.” Each paragraph uses a custom paragraph style, and the 
whole text box has a dark red fill and a thin black border. The red fill will get stripped out 
in portrait orientation, leaving just white text on the standard white background, which 
is probably not a good idea.

To create your own sidebar (Figure 3-13), just add a new text box and give it a custom 
background, stroke, and text inset, and decide if you want it inline or floating (see 
“Anchors” (page 53)). Then you can use Copy Graphic Style (see “Copy Graphic Style” 
(page 54)) to reuse this design throughout your book.

However, remember that if your sidebar boxes aren’t anchored inline, or if you don’t 
create a custom label for them in the Widget Inspector, then they’ll disappear when 
readers switch to portrait orientation. This means that if you absolutely must have free-
floating sidebars that appear in both portrait and landscape orientations, your best bet 
is to turn them into widgets by adding a label. You have complete control over widget 
formatting: you can add custom borders and backgrounds, just like with plain text 
boxes, and style the labels and captions in any way you please. See “Anchors” (page 53) 
for more on inline versus floating objects, and see “Media” (page 60) for instructions on 
adding custom widget labels.
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Figure 3-14. The Format Bar gives you special tools when you’re working with tables.

Tables
To add a table to your book, click the Table button in the toolbar, and Author drops a 
new, blank table into the middle of your page. By default, your table is set to float (see 
“Anchors” (page 53)), so you can drag it wherever you want on the page, and that’s where 
it’ll stay. If you want your table nested in the flow of the text, click the Inline button in 
the Format Bar, and your table will pop over to wherever you last had your text cursor.

To add data to your table, click in a cell and type away. If your text is too long to fit in 
the cell, it will wrap onto a new line and the cell will resize vertically. To resize the cell 
horizontally so that more text can fit on one line, you have to resize the whole column 
(unless you want to merge two cells; see below). Click the edge of the column that you 
want to make bigger—your cursor will turn into a double-headed arrow that you can 
drag to resize the column.

The whole table doesn’t resize as you resize a column by dragging; instead, your 
new column eats up the space of the column next to it. To get it right, you’ll have 
to resize all the columns in your table, starting with the last and moving in to the 
column you originally wanted to resize. This isn’t a problem if you resize via the 
Table Inspector (see below).

In addition to the usual text options in the Format Bar, you get a few extra choices when 
you’re working with tables (Figure 3-14). First, you’ll notice there’s a new paragraph 
alignment button: “Auto-align table based on content type.” This clever button can tell 
if your table cells contain text or numbers, and aligns the cell contents to the left or right, 
accordingly. Next to that are the vertical alignment buttons, which let you align text at 
the top, middle, or bottom of a cell. Select a single cell to change the alignment of just 
that cell, or select the whole table to change all the text.

With the next couple of buttons, you can add rows or columns to your table, and if your 
table has empty rows or columns at the end, you can remove them here, too (but you 
can’t subtract rows or columns here if they contain text). Use the up and down arrows 
to choose how many rows and columns you want.

Use the fill box to set the fill color of selected cells, rows, or columns (but not the entire 
table). Select the cells you want and click the swatch to choose a color.

To select multiple cells, hold down the shift key and click the cells you want. You 
can also select whole rows or columns this way, or right-click or control-click 
on any cell in the row or column and choose “Select Row” or “Select Column.”
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Figure 3-15. Here’s an example of a table with merged cells (middle top), a cell split into 
rows (top right), and a cell split into columns (bottom right). You can merge and split cells 
by selecting one or more cells and then control-clicking or right-clicking and choosing one 
of the merge or split options from the context menu.

Finally, you have the anchor options (see “Anchors” (page 53)) and text wrap (see “Text 
Wrap” (page 53)).

When you right-click or control-click on a table, you can choose how many header 
rows, header columns, or footer rows to give your table, and you can also add or delete 
rows and columns, and split or merge cells (Figure 3-15). To merge two cells into one 
big cell that spans multiple rows or columns, select the cells (they must be adjacent to 
each other), right-click, and turn on Merge Cells. To split cells that you previously 
merged, right-click again, and turn off Merge Cells. The split options divide a cell into 
two cells, each taking up half the column or row (but you can adjust the sizes if you 
want).

Table Inspector
Naturally, Author has a special Inspector just for tables, where you can adjust the for
matting even more. To get to the Table Inspector, click Inspector from the Toolbar and 
choose the Table tab (fourth from right). There are two tabs here: Table and Format. 
The Table tab has all the visual formatting options, and Format has some special 
spreadsheet-like options to control the data in your cells.

Here’s what you get in the Table tab:
Body Rows and Body Columns

Just like the buttons in the Format Bar, these boxes let you add rows and columns, 
or remove them as long as they don’t contain any text. (To delete rows or columns 
that contain text, you need to right-click or control-click and choose Delete from 
the menu that pops up.)
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Headers & Footers
Choose how many header and footer rows to have, and whether to have header 
rows along the top or along the right side (or both).

Edit Rows & Columns
Gives you the same options you get by right-clicking or control-clicking: Add rows 
or columns, select, delete, merge, and split. You can also sort the cells in a column 
in ascending or descending order. To use this option, you need to have a cell selected 
rather than the whole table; then choose the sort style you want, and Author reor
ders the rows in your table so that cells in the column you chose are sorted appro
priately.

Column Width and Row Height
Adjusts the size of your rows and columns, if you don’t want to drag. The benefit 
of resizing this way is that your table will shift over, instead of the resized row or 
column poaching space from the ones next to it. You can’t size a row or column 
smaller than the amount of space needed by the text within it, though.

Cell Borders
Adjust the line width and color of the borders of individual cells or the entire table. 
Choose which border you want to format by clicking the appropriate button, and 
then choose the line style, weight, and color.

Cell Background
Add a background color to one cell or a group of cells (but not the entire table). 
You can choose either Color Fill or Gradient Fill. For Color Fill, click the swatch 
to choose the color you want from the color picker. For Gradient Fill, choose the 
two colors you want the gradient to blend together, choose an orientation (blend 
vertically or horizontally), and set an angle to skew the orientation if you want. 
Gradients are a risky design choice, and could make your book look amateurish, 
so use them judiciously.

At the bottom of this section, turn on the Alternating Row Color checkbox to au
tomatically fill alternating rows with a color you choose (by clicking the swatch). 
This adds a visual distinction between rows, which helps readers navigate your table 
more easily.

Table Options
There’s only one checkbox here: “Return key moves to next cell.” Turn this on, and 
when you have a cell selected, all you need to do is hit Return to select the next cell.

With the Format tab, you can turn your table into a mini-spreadsheet. Here are your 
options:
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Figure 3-16. The top row in this table has a custom condition applied that turns a cell 
green if the value is greater than 35. You can create your own conditions and add formulas 
to your table to make it smarter.

Cell Format
Tell Author what the contents of the cell are: plain text, a number, a date or time, 
and so on. You get some further formatting options based on what you choose from 
the drop-down—how many decimal places to show (for numbers), what date for
mat to use, etc.

Conditional Format
Apply custom formatting to a cell or its contents depending on if it meets certain 
conditions (see Figure 3-16). For example, add a green background to every cell 
containing a value higher than 100. Click Show Rules to add a new condition. There 
are a number of variables you can choose from, making it almost infinitely cus
tomizable for your data.

Function
Perform some mathematical calculations and show the results in your cell. You can 
choose one of the predefined functions: Sum, Average, Min, Max, Count, Product. 
If that doesn’t do it for you, you can build your own with the Formula Editor. Apple 
put together a helpful guide about formulas and functions that you can download 
for more info.
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Wrap Text in Cell
Turn this on and your cells will automatically grow to fit your text. If you turn it 
off and your text gets too long, it’ll just disappear past the cell borders.

Adding Pages
When you import text, Author will automatically add as many pages as needed to fit all 
your content, and it will keep adding pages as your content shifts. However, if you’re 
adding text on a page-by-page basis, or you want to add extra pages, click the page 
thumbnail that you want to add pages after, click the Add Pages button in the top left 
of the Toolbar, and choose the page layout style you want your new pages to use 
(Figure 3-17). Once your pages are there, you can’t move them around, so make sure 
you get them in the right spot.

Adding sections and chapters works the same way. Select the section or chapter that 
you want to add pages after, choose Add Pages, and choose the chapter or section type 
that you want to use. Unlike individual pages, you can rearrange your sections and 
chapter by dragging them around within the Book menu.

You can change the layout for any page, section, or chapter. Select the page in question 
and click the little arrow that appears to the right. You get a list of all the available layouts 
to choose from. (For more about layouts, see Chapter 5.)
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Figure 3-17. Add pages with the click of a button, and change a page’s basic layout by 
choosing one of the layouts from the drop-down menu.
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CHAPTER 4

Objects

An object is basically any nontext part of your book. Even text boxes are objects (but 
the paragraphs within them aren’t). Read on to learn about the different objects you 
can create and how to format them.

Images
Images are a basic way to spice up your book. To add one, drag it from Finder or the 
Photos tab of the Media Browser. You can drag images into the placeholder image boxes 
that come with your chosen Template, or you can just drop them anywhere in the file. 
If your image is too big to fit where you want, resize it by clicking it and dragging one 
of the resize handles located evenly around the edges. The image scales proportionately 
to its original size.

Select an image, and the Format Bar changes to cater to your selection (Figure 4-1). The 
Styles Drawer button is still there, even though there aren’t any object styles. Next to 
that are options to add a stroke to your image. Author gives you a lot of sleek stroke 
and border styles to choose from. If the canned options aren’t enough, choose Show 
More... at the bottom of the list to create your own custom border. This opens the 
Graphic Inspector.

Figure 4-1. When you’re working with objects, the Format Bar adjusts to give you the 
basic tools you’ll need.
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Graphic Inspector
There’s only one tab in the Graphic Inspector. The first choice—Fill—lets you add a 
background color to your selected object. This is generally only an option for shapes or 
text boxes (images are already filled with, well, themselves).

Your next choice is Stroke. Choose a base style to work with from the drop-down list: 
line or picture frame (“none” means no border at all). Line and picture frame give you 
different options within the Graphic Inspector. If you choose line, your choices are as 
follows:
Style

Choose from solid, dotted, dashed, and a handful of hand-drawn styles.

Color
You’ve got the whole rainbow to choose from, but try to keep your color usage 
consistent throughout your book, or it could become distracting for readers.

Width
How thick the line is.

Choosing picture frame instead of line changes the first three options to the following 
two:
Frame style

You have 12 choices, and all of them are pretty cool. Choose the one that works 
best with your book.

Scale
How much of a border/frame to add around the image. Typically, smaller scale 
means a thinner frame.

There are a few more options after you set up your stroke:
Shadow

Turning this on adds a drop shadow to your image (Figure 4-2). If you choose this, 
you get some extra options just for customizing the shadow:

• Color. The default color for the shadow is solid black, which is usually perfect. 
However, if you’re going for the psychedelic-mist look, click the black swatch 
to get to the color wheel, and drag the slider up until you can see some color, 
and then choose the one you want.

• Angle. Adjusts the balance of the shadow beneath your image. You can use the 
little wheel or the up/down arrows to change the angle. Watch your image as 
you adjust it and stop when it looks right.

• Offset. Shifts the shadow farther up or down behind your image, making it 
seem like the light is pointing down at a steeper angle.
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Figure 4-2. Here’s an image with a drop shadow and an opacity of 45 percent. It’s floating 
over the text with no text wrap (please don’t do this to your poor readers).

• Blur. Diffuses the shadow farther out around your image.
• Opacity. Makes your shadow more or less visible. By default, it is usually set at 

100 percent.

Opacity
Turns your image more or less transparent. Setting the opacity to 100 percent means 
you can’t see anything behind the image; the lower the opacity, the more see-
through the image becomes (Figure 4-2).

Once you’ve settled on a stroke and shadow style, head back to the Format Bar for some 
extra image styling options.

Levels
Click the levels button to open the Adjust Image window, where you can sharpen up 
your image and tweak the color balance to get a nice clear look (or massively distorted, 
if you prefer). Click Enhance to give your computer control, letting it decide how your 
image will look best. This usually turns out pretty well, but some people like to have 
extra control. If you’re one of those, you can play with the following settings: Brightness, 
Contrast, Saturation, Temperature, Tint, Sharpness, Exposure, and Levels.

Images | 51



Figure 4-3. Add a mask to focus on just a portion of an image. The parts of the image that 
won’t be visible appear muted; drag the image to the correct position within the mask 
shape, and adjust the size of the mask with the slider. You can even add a stroke to the 
mask, to make it stand out.

We’re not going to dive too deep into the different image level settings, but if 
you need more info, check out this Apple support page. It was written for their 
Pages application, but the options are the same.

If you’ve gone through all that, and decide you liked your image better before, just click 
Revert to get back to the original.

Mask
Next to the levels button is mask (Figure 4-3). Click to add a mask to your image, or 
click again to get rid of it. Adding a mask is kind of like cropping—it shows just a portion 
of the image. You can change which part of the image is shown by clicking and holding 
the image; your cursor turns into a little hand, and you can drag the image around 
behind the mask until the correct part is showing. Resize the image behind the mask by 
dragging the slider up and down. Once you’ve got your mask all set, you can resize the 
whole thing by clicking one of the resize handles around the mask window.

You can also add a mask by selecting the image and choosing Format → Image → Mask 
or Mask with Shape; see “Mask with Shape” (page 54) for more details.
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Next to the mask button, you have another chance to adjust your image’s opacity and 
to turn the drop shadow on or off.

Anchors
The next three options are active or grayed out depending on how you added the image. 
If you dragged it onto some empty white space, these options are inactive. However, if 
you dragged your image into an empty paragraph or inline with some text, these buttons 
come into play. Choose Inline to leave your image just as you inserted it. Floating takes 
your image out of the text flow and lets you move it anywhere on the page. If you move 
paragraphs around or delete the paragraph where you originally placed the image, your 
image will be unaffected, and stay right where you put it.

Anchored is usually a better option than floating (at least in landscape view; see the 
Warning below). It lets you tie your image to a specific point within the text, while still 
being able to drag it around on the page. This means that as you add or delete paragraphs, 
your image will stay on the same spread as the text it is anchored to. The image always 
shows up in the same position on the spread, however; for example, if you placed your 
image in the bottom right corner of the page, and anchored it to some text in the middle 
of that column, if that text then moves to the top of the first column on the next spread, 
your image will move to the bottom right corner of that new spread, in the same position 
as it was on the previous spread. It’s not perfect, but it’s a handy way to keep an image 
close to the paragraph that describes it.

Any static image or text box that you add either as floating or anchored will 
disappear in portrait orientation (but if you add it inline, it’ll show up fine and 
in the correct place). However, if you turn it into a widget (by adding a label; see 
“Figures” (page 55)), then it will be preserved in the margin in portrait view. 
Remember that you can add custom widget labels too; see “Media” (page 60).

Text Wrap
Your last option in the Format Bar is text wrap. The style you choose here dictates how 
text will flow around the image when they overlap. You have six choices: wrap to the 
left, wrap around, wrap to the right, wrap to whichever side has the most space, and 
wrap only above/below. You can also choose no wrap, but if your image overlaps any 
text, that text won’t be visible.

You can also adjust the float and text wrap in the Wrap Inspector (third icon 
from the left in the Inspector window). You have extra choices here: how to wrap 
around the shape of the image and how much space to add between the edges of 
the image and the wrapped text.
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Figure 4-4. Use Instant Alpha to make this tarsier’s eyes transparent. Using the Instant 
Alpha tool, click a location on the eye, and drag out to expand the transparency area. All 
similar colors to the one you clicked will turn blue to show they’ve been selected.

Instant Alpha
With Instant Alpha you can choose to make parts of your image transparent 
(Figure 4-4). Click to select the image, and then go to Format → Image→Instant Alpha. 
Author opens a little tip to help get you started, but here’s how it works: click on a color 
with the crosshairs to make that color transparent; drag to select more areas of the image 
around your original selection and make them transparent too, or click again on parts 
of the image that aren’t connected to your original selection. It usually works pretty 
well, but takes some getting used to and can sometimes give you unexpected results.

Mask with Shape
This works just like the mask tool described above, but instead of a boring rectangle, 
you can choose almost any shape to use as your mask. Only the parts of the image that 
overlap with the shape will show. Go to Format → Image → Mask with Shape, and choose 
the shape you want from the menu. Author places the shape on top of your image, and 
you can resize both the image and the shape and move the image around behind the 
shape to get the correct parts to show.

Copy Graphic Style
If you do a lot of customizing and get a style that you really like, you can copy that style 
and use it on other images throughout your book. Select the image and choose For
mat → Copy Graphic Style. Then select the new image you want to style, and choose 
Format → Paste Graphic Style. Your new image should now match the first.
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Figure 4-5. Use the Widget Inspector to turn your images into official numbered figures, 
complete with title and caption.

Unfortunately, Copy Graphic Style only remembers one style at a time, so if 
you’ve got multiple image styles that you’re using throughout your book, you 
have to make sure you have the right image style copied to your clipboard before 
you paste. No harm if you accidentally paste the wrong style though; just undo 
and copy the correct style, then try again.

Figures
You can turn any Floating or Anchored image into an official, numbered figure in your 
book via the Widget Inspector (Figure 4-5). Select the image, and then go to the Widget 
tab in the Inspector (the last icon at the top). Turn on the Title checkbox, and choose 
Figure from the label drop-down.

You can’t turn an Inline image into an official figure; when you select the image, 
the Title checkbox will be grayed out in the Widget Inspector. If your image 
absolutely must have a title, you’ll need to convert it to Floating or Anchored 
first (see “Anchors” (page 53)).
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Author wraps your figure in a box and adds a figure number as well as placeholder text 
for a caption. You can change the position of the caption in relation to the image in the 
Widget Inspector: click the arrow next to Layout, and choose the arrangement you want. 
Drag to adjust the size of the figure box; the image will resize to fit the box, but you can 
resize it further as needed.

There are a few other options in the Widget Inspector. Turn on Caption to add more 
space for an extended description of the figure. Turn off Background to make your 
figure and caption seem like they float, rather than sit in a box. Drag the Margin slider 
to add more or less space between the figure content and the edges of the box.

The Accessibility Description box lets you describe the figure for readers who are sight-
impaired. The only option when it comes to Interaction is to make the image full-screen 
only. This shrinks your figure down on the page; readers would have to click the mini-
figure to see it in full-screen view. You can change your mind about full-screen view at 
any time, and your figure reverts to the boxed style.

Author takes care of auto-numbering your figures and other labeled objects for 
you, so you don’t have to worry about how many you’ve added and where. Au
thor numbers each label type separately, so, for example, you can have a 
Figure 3-1 as well as a Movie 3-1. If you want to create your own label, in the 
Widget Inspector, open the Label drop-down and choose Edit Label Styles.... 
Here you can add new labels and choose how to number them and change or 
delete the existing styles.

Shapes
Author comes loaded with 15 shapes you can add to your book; if you still can’t find 
what you’re looking for, you can use the pen tool to draw your own shape (Figure 4-6). 
To do so, click to create your shape outline, as if you’re making a connect-the-dots 
puzzle. To finish, either click your first endpoint again, or press Escape. Don’t worry if 
some of your shape’s points are slightly off—you can change them. Double click any of 
your shape’s endpoints, and they’ll turn red. You can now drag them around as needed. 
To round the edges, click again on any of the red points, and two extra little handles 
will appear. Pull and move the handles to create different curves from your formerly 
pointy peak.

To adjust the formatting of any shape—canned or drawn—use the Graphic Inspector 
(see “Images” (page 49)). To rotate a shape, hold down the control key and hover your 
cursor over any of the shape’s endpoints—it’ll turn into a curved arrow. Then, still 
holding down control, click and drag the shape to the correct orientation.

Shapes can add some nice embellishment to your book, but be careful not to go over
board and clutter your pages.
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Figure 4-6. Draw your own shapes using the pen tool. Edit your endpoints by double-
clicking and dragging the red dots. Make curves by clicking one of the red dots and pulling 
the handles extending out on both sides.

Charts
Charts are a great way to visually represent data, and Apple has designed some nice 
ones for you to use. Click the Charts button in the Toolbar (or go to Insert → Chart) 
and Author gives you a list of the different kinds of charts you can choose. There are 
11 options, 8 of which have both 2D and 3D versions. Choose the chart that’s right for 
your data, and Author unceremoniously drops it onto the middle of your page.

This isn’t a book about charts and data visualization, but there are lots of re
sources out there to guide you in the right direction. For an overview of the most 
popular charts and when to use them, check out this article on mindtools.com. 
For a purely visual (and fun) guide to data visualization, check out the “Periodic 
Table of Visualization Methods.”

Along with your chart, you get a table filled with placeholder values—this is the Chart 
Data Editor, where you add the data for your chart. Change the data values in the Chart 
Data Editor. To delete a column, click any cell within that column, and then right-click 
anywhere except the header row, and choose Delete Column. Adding a column generally 
adds another data point to your chart, and adding a row adds another data set. For 
example, if you chose a line chart, adding a new column will add another axis in your 
lines, and adding a row will add a whole new line to the chart. Click in the table cells to 
change the values, and do the same to change the labels. You can also change the labels 
by clicking directly on them in the chart, and you’ll see the Chart Data Editor update 
to match your change.
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You can adjust the way your chart looks in the Chart Inspector (Figure 4-7). To open 
it, click the Inspector button in the toolbar, and choose the Chart tab (third from the 
right). Your options in the Chart Inspector vary depending on the type of chart you 
choose. Turn on Show Title to add a description to your chart. Toggle Show Legend on 
or off to show information about what each part of the chart represents.

Figure 4-7. Add a chart, customize the data, and make it shine with the Chart Inspector.

If you managed to get Author working on Mac OS X Snow Leopard or earlier, 
you don’t get to play with the 3D chart options. These depend on the Scene Kit 
framework, available in OS X Lion. It may seem like you can add one, but Author 
slows to a crawl and your chart just looks like a garbled mess.

Widgets
Widgets are special sidebars tailored for specific kinds of content. Use them to add 
image galleries, slideshows, video and audio, and more.

If you add a widget to the first page of a chapter, it won’t appear in portrait 
orientation.
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All the widgets have the same boring formatting by default, but you can customize them 
using the tools in the Graphic Inspector—for example, by adding a stroke or picture 
frame, a custom background color, and so on. However, Author will remove any custom 
background colors when the book is in portrait orientation, so white or light-colored 
text probably isn’t a good idea.

Gallery
With the Gallery widget, you can package multiple images in a single sidebar to create 
a mini photo gallery. Click Widgets in the Toolbar, and choose Gallery. Author adds 
an empty sidebar to your page, with some placeholder text and a spot for you to add 
images. Drag an image onto the picture icon in the sidebar to add it to your gallery, and 
keep dragging images one on top of the other to add them all.

With the Widget Inspector, you can change the layout of your Gallery sidebar and add 
or remove images. There are two tabs: Layout and Interaction. See “Figures” (page 55) 
for the details about the Layout tab. One important checkbox here for galleries is the 
Caption—you can set all the images in your gallery to share one caption or add a dif
ferent caption for each one. Use the arrows in the bottom left and right corners to 
navigate between images, and click the caption placeholder text to add your own cap
tion.

You can add different captions for each image, but you can only have one title 
for your Gallery sidebar (if you choose to have a title at all—see “Images” (page 
49)).

Head over to the Interaction tab to add or remove images from your Gallery and to add 
an Accessibility Description for each image (Figure 4-8). Turn on the Show Thumbnails 
checkbox at the top to add thumbnails of your Gallery images to the bottom of your 
sidebar, to give your readers a visual way to navigate between them.

You can’t make a Gallery full-screen only.
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Figure 4-8. Add or remove images from your Gallery via the Interaction tab in the Widget 
Inspector. Turn on Show Thumbnails to add a row of icons below your gallery for easy 
navigation. Make sure you also remember to add an accessibility description.

Media
To add a movie or audio file, click Widgets in the Toolbar, and choose Media. Author 
immediately plunks a special box in the middle of your page, prefilled with a placeholder 
title, a spot for the file, and a placeholder caption or description. Grab any of the nontext 
areas of the box, and drag it to the desired location on your page (Figure 4-9).

You can ditch the Media Widget and just drag and drop an audio or video file 
right from Finder or the Media Browser onto a blank spot in your book, but the 
end result is the same. With the drag and drop method, Author adds the media 
file within a figure box (“Figures” (page 55)), which you can change in the Widget 
Inspector.
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Figure 4-9. You can add an audio or video file in just a few clicks and drags.

Author only supports one movie format—.m4v (H.264)—and one audio format
—.m4a (AAC). If your files aren’t already in this format, you can convert them fairly 
painlessly.

For audio files, open the file in iTunes. Right-click or control-click on the file name, 
and choose “Create AAC Version” from the context menu. There are then a couple of 
ways for you to get the file into your book. You can use Author’s Media Browser—click 
the icon in the top right corner of the Toolbar, and navigate to your movie file. The 
Media Browser doesn’t give you a lot of information about the files it finds, though, so 
if you have multiple movies with the same name (for example, if you made a copy with 
a different file type but didn’t rename the file), it’s hard to tell which file is the right one 
without a lot of trial and error. For a sure-fire way to get the right file, drag it from 
Finder. Right-click or control-click on your converted file in iTunes, choose “Show in 
Finder,” and drag the file from the Finder window that pops open into your book.

You may need to make some changes to your iTunes Preferences to get the 
“Create AAC Version” option. Here’s a tutorial from Apple about changing those 
settings..

For movies, open the file in QuickTime, and choose Share → iTunes.... For a smaller 
file size, choose the iPhone setting; for larger, choose AppleTV (or Computer, if it gives 
you the option). Use the same methods to add the file to your book as you would for 
audio.

As with all placeholder text, click on it once to select the whole passage, and type or 
paste your own text instead. Once you’ve added all your text, resize the media box so it 
fits everything and doesn’t have too much white space.

To create a custom label for your widgets—for example, if you’ll be adding a series of 
lectures throughout your book that you want labeled “Lecture”—go to the Layout tab 
of the Widget Inspector (Figure 4-10). Choose Edit Label Styles from the Label drop-
down, and click the + button in the list that appears to add a new label. Give it a new 
name, set a numbering style and a character style in the two boxes on the right, and 
then click Done.
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Figure 4-10. Create your own custom label for your widgets from the Layout tab of the 
Widget Inspector. Your new label will appear in the Label drop-down menu for all your 
widgets.

Watch Your File Size
Movies are pretty big files—usually at least dozens of megabytes large, if not a gigabyte 
or more. (To give you some context, the average O’Reilly Media ebook is about 10 meg
abytes.) This means that every media file you add is going to bump up your book’s file 
size exponentially, making it take longer to load on your readers’ iPads and taking up 
more of their storage space. Your best bet is to limit yourself to just a few video clips where 
they’re most needed. If you’ve got a lot of large videos that are crucial to the book, consider 
releasing them as a supplemental movie or a webcast.

Review
Quiz your readers along the way with Review widgets (Figure 4-11). These handy little 
boxes let you build multipage question-and-answer exercises that you can place any
where in your book. To use, click Widgets in the Toolbar, then choose Review. Author 
inserts a special sidebar on your page with one test question filled with placeholder text. 
You can add as many questions as you like to this box, and readers can use the arrows 
at the bottom of the box to move from question to question.

There are six different styles of quiz questions: basic multiple choice, three kinds of 
multiple choice with an image, adding text labels to an image, and adding image labels 

62 | Chapter 4: Objects



to an image. To add a question to your sidebar using one of the other styles, use the 
Widget Inspector. Author should automatically open the Widget Inspector as soon as 
you insert your Review box, but you can also open it yourself by clicking the Inspector 
button in the Toolbar and going to the Widget tab (the very last icon along the top).

Use the + and – buttons to add or delete questions. When you click the + button, you’ll 
get a drop-down list of all the styles. Choose one, and Author opens it up in your Review 
box, and also adds it to the list in the Widget Inspector. You can change the number of 
possible answers by choosing a different number from the dark gray box to the right of 
the question. To change the actual question text and answer options, just type over the 
placeholder text in the Review box. For questions that involve images, drag the image 
you want from the Finder or from the Media Browser into the appropriate image box 
(marked with the usual little picture frame icon).

The image containers act like masks right off the bat (see “Mask” (page 52)), but click 
the image to adjust the mask slider or reposition your image within the mask.

Your image must fit the full width of the Review box, so if you’re trying to adjust 
the size and it seems frozen, it means you’re probably at exactly the minimum 
width; adjusting the size of the Review box itself should do the trick.

Author labels the Review box with a number and caption. Type over the caption place
holder text to add your own, or to get rid of it entirely, go to Layout in the Widget 
Inspector, and turn off the Title checkbox.

Keynote
Remember that great presentation you put together using Apple’s Keynote application? 
Well, you can include that in your book, too! Click the Widgets button in the Toolbar 
and choose Keynote. Once again, Author drops a box into the middle of your page that 
looks like all the other widget boxes, with the label “Presentation.” Drag a Keynote file 
into the middle of the sidebar, and it’s now embedded in your book (Figure 4-12).

You can edit all the usual formatting options via the Widget Inspector, but this is really 
where the “Full-screen only” option shines, letting your readers jump to a full-screen 
view of your presentation at will.

I Love PowerPoint!
Sadly for you, Author only accepts Keynote files, not PowerPoint. The good news, how
ever, is that Keynote will gladly open a PowerPoint file and convert it for you. To do so, 
either right-click your PowerPoint file in Finder and choose Open With... → Keynote, or 
open Keynote, go to File→Open, and choose your presentation from the menu. Your 
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Figure 4-11. Sure, you can add plain old multiple choice quizzes, but you can also spice 
up your review widgets with interactive images and labels.

Figure 4-12. Adding a slideshow to your book is a great way to spice up your reader’s 
learning experience.
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Figure 4-13. With interactive images, you can guide your readers through different parts 
of a large image, giving them details along the way. Here you see the default view for an 
interactive image (left) and the view for one of the labels (right).

presentation should import seamlessly, but if Keynote encounters any errors, it’ll open 
up a Warnings window to tell you what happened. Scan through your slides to make sure 
everything looks okay, and then choose File → Save As to save your file as a Keynote 
presentation that you can add to your Author book.

Don’t have Keynote? It’s only $19.99 from Apple’s App Store.

Interactive Image
If you’ve got a really big image with a lot going on, it might make more sense to add it 
as an Interactive Image. With this widget, you can tag different parts of an image with 
their own descriptions and custom zoom levels (Figure 4-13).

To add one, click the Widgets button in the Toolbar and choose Interactive Image. It 
comes equipped with two interactive labels, but you can add or subtract as needed. Drag 
your image into the middle of the box, and then start adding interactivity. Click a label 
and Author will arbitrarily zoom in to a random place on your image; adjust the zoom 
slider and drag your image until you get it right. Click to edit the text label and de
scription, and then click “Set View.” Repeat with the second label, and add more with 
the + button next to the zoom slider. Don’t forget to set a default view, too.

It can get a little dizzying with all the clicking and zooming in and out. For a more 
controlled experience, use the Widget Inspector. The Layout tab has the usual options, 
but the Interaction tab gives you a text-based way to control your sidebar. You’ll see all 
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your labels listed in the Views box—click one to see its settings and make changes, and 
drag the labels up and down in the Views box to rearrange them. You can also add 
accessibility descriptions for each view in your image, and for each part of the view 
(Label Title, Label Description, and Label Target).

Turn on the “Show transport controls” checkbox to give your readers another way to 
interact with your image, using little buttons at the bottom of the sidebar. “Show de
scriptions in sidebar” will add the descriptions for your labels as sidebars running along 
the edge of your image, instead of expanding the label.

3D
Add 3D Collada (.dae) files to your book that readers can look at from every angle 
(Figure 4-14). Collada files can be created with a few different kinds of software, in
cluding Google SketchUp Pro (but not the free version, unfortunately). For more about 
Collada, check out the Wikipedia entry. Author’s 3D Widget capability is powered by 
the Scene Kit framework, new in Mac OS X Lion (10.7), which means if you managed 
to get Author working on OS X Snow Leopard or earlier, you’re out of luck when it 
comes to 3D Widgets (and 3D charts, for that matter—see “Charts” (page 57) above).

To add a 3D widget, go to Widgets → 3D. Move the box wherever you want, and drag 
your Collada file to add it. Aside from the Layout options, the Widget Inspector only 
really gives you one more choice for 3D widgets—how to rotate it. Choose Free Rotate 
to let readers rotate in any direction, or choose Horizontal or Horizontal and Vertical 
for a more sedate rotation. If you turn on “Auto-rotate object when idle,” your object 
will spin about lazily even when readers aren’t using it.
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Figure 4-14. Use 3D widgets to include interactive 3D models in your book. Add the widget 
to your book in the normal fashion (top), and readers can drag over the image to see it 
from every angle (bottom). (Image courtesy of Anthony Scavarelli.)

HTML
If none of the other Widgets do it for you, you can create your own in the Dashcode 
application, using HTML. Dashcode comes installed on all new Macs these days, and 
Apple put together a tutorial to walk you through building your own widget in Dash
code, available here.
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Make sure your .wdgt file includes a Default.png file to display when the HTML 
Widget is inactive.

HTML widgets work the same as all the others: Drag and drop Dashcode Widget files 
(.wdgt) into the box, and edit the layout options on the Layout tab in the Widget In
spector. HTML widgets can only appear full-screen in your book (they’ll appear as small 
buttons or sidebars in the text), and if you want to test out the widget, click the Edit 
HTML button. The button label is deceiving—this doesn’t open a code editor, but in
stead gives you a preview of your widget in full-screen mode (Figure 4-15).

Figure 4-15. Create your own widget with HTML and add it to your book. (You can play 
with the widget pictured here in HTML5 for Publishers by Sanders Kleinfeld, also free 
and available from O’Reilly.)
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CHAPTER 5

Layouts

You can create your own Chapter, Section, and Page layouts and add them to your 
Layout menu to use throughout your book. Go to View → Show Layouts, and a new 
section opens up above the Book menu showing all the different layout options. Click 
one, and it opens in the editing window. If all you want to do is make a few small changes 
to the canned layout, go ahead and do that here. A big red button will appear next to 
the page thumbnail in the Layouts window after you make a change; click it to apply 
your changes to the layout, which will also add them to any pages in your book that 
currently use that layout.

If you want to make a brand new layout from scratch, make sure you have a layout 
selected from the type you want to create (either Chapter, Section, or Page), and then 
in the Toolbar, click the Add Layout button (when you’re editing your regular pages, 
this button reads Add Pages). A new page or spread gets added to that group. Click 
twice on the name of the new page to rename it.

In many other page layout programs, these kinds of layout pages are called master 
pages, because they control how all the rest of the pages look.

You can add as much as you want to a layout page—colorful boxes, footers with the 
page number, running headers with the chapter title or section title... the sky’s the limit 
(Figure 5-1)! If you want to be able to change your layout elements on a page-by-page 
basis, select that element and in the Layout Inspector turn on the “Editable on pages 
using this layout” checkbox.
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Figure 5-1. Here’s a simple layout body page with a running header containing the current 
section number (see “Text Variables” (page 71)), a running footer with the page number, 
and two linked text boxes tagged as body text (see “Text Flow and Tags” (page 72)).

This option is only available when you’re editing a layout, not on regular pages.

Layout Inspector
Everything has an Inspector in Author, and Layouts are no exception. The Layout In
spector gives you some basic tools to adjust the main elements on your page, and also 
lets you set the section and page numbering.

On the Layout tab, you only have a few options. If you have a text box selected, you can 
set how many columns it should have, and how wide each column should be, and if 
you’re looking at a layout page, you can choose to make your page elements editable on 
regular pages and tag your text boxes (see “Text Flow and Tags” (page 72)).

The Numbering tab is only active when you’re looking at a regular page, not a layout 
page. This is where you decide how to number your sections: relative to the whole book 
(meaning all sections will be numbered sequentially, no matter what chapter they’re 
in), relative to chapter (section numbering will restart at 1 with each new chapter, and 
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will be preceded by the chapter number—1.1, 1.2, 2.1, and so on), or not at all. You can 
also set what page number to start each section on. Leave “Continue numbering” se
lected if you want to number the book sequentially, or type a number in the “Start at” 
box for the section you currently have selected.

Text Variables
In the Insert menu, Author offers you four text variables that you can insert on your 
pages: Section Title, Section Number, Page Number, and Page Count. When you add 
a variable to your page and select it, it shows up inside a blue box—this is your visual 
cue that the text is dynamic. Dynamic text refers back to a master text field and mirrors 
whatever is typed there. So, for example, the main text field for a section title is on the 
first page of the section, and whatever you type there will be reflected in any section title 
variables you’ve inserted (Figure 5-2).

Figure 5-2. Working with text fields and variables can be tricky, but it is a big time-saver, 
especially when setting up your Layout pages. Use them to add running headers and footers 
throughout your document. In this figure, the chapter title at top left is a text field, telling 
the running footer (bottom right) what to display.
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Remember that Author is touchy about letting you edit text fields within your 
pages. See the Warning in “Importing a Text File” (page 25) for more info.

Text Flow and Tags
Author seems to still have some kinks to work out when it comes to getting text to flow 
between pages and text boxes, but as long as you know the tricks, you can get it working 
just fine.

To get text to flow, you need to add text boxes to your Layout pages. For each text box, 
turn on “Editable on pages using this layout” in the Layout Inspector. You also need to 
tag the text box. Author uses tags to know what kind of text should go in each box. Then, 
if it runs out of room in one text box, it can just find the next text box with the same 
tag and flow the rest of your text in there.

Note that you can only use a tag once per page. However, if you tag a text box, and then 
create a new linked text box by clicking the blue arrow on the right edge of the box, near 
the bottom, your new text box will share that same tag. When you switch to your regular 
text pages, you can add more linked text boxes from your default layout boxes by clicking 
the blue arrow and clicking again on the page.

You can’t create linked text boxes from static text boxes you add to your book 
pages (that is, text boxes that aren’t part of the Layout page).

You can split a text box into columns to get a structured design grid to help you lay out 
the pages. When working with a single columnar box, you can give each column in your 
text box a unique width. In the Layout Inspector, turn off the “Equal column width” 
checkbox, and then type the values you want in the list. You can also tell Author how 
much space to add between columns in the Gutter column.

If you go the multicolumn text box route, use column breaks to adjust the amount 
of text in each column; see “Column and Page Breaks” (page 41).

One thing you can’t do with a multicolumn box is apply different vertical alignment to 
each column. For example, you can’t have the text in the first column aligned to the top 
of the box, and then have the text in the second column aligned to the bottom. You’re 
better off using separate text boxes for this (Figure 5-3).
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Figure 5-3. Two custom layout pages; one uses two static linked text boxes (top) and the 
other uses a single text box split into two columns (bottom).
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Save as Template
If you’ve heavily customized your layout, you can save it as a new template and use it 
for future books. Choose File → Save as Template, give it a unique and meaningful name, 
and click Save. The next time you start a new Author project, you’ll see your template 
listed in the Template Chooser.

Creating Complex Layouts (Tutorial)
The easiest way to learn is to do, so in this section you’re going to walk through recreating 
one of the layouts from the Life on Earth free sample from the iBookstore—pages 27 
and 28.

Step 1: Set Up the Page Structure
First, go to Author → Preferences, and in the Rulers tab, choose Points as your unit of 
measurement.

Create a new document using the Basic template, and add two more blank pages after 
page 3 (Toolbar → Add Pages → Pages → Blank). You want your pages to form a spread
—a pair of facing pages. In a printed book, if you have the book lying open in front of 
you, the two pages you see form a spread.

Two contiguous even and odd body pages (eg, page 4 and 5) will automatically 
form a spread when exported to the iPad, though it may not look like it in Author.

Make sure the rulers are turned on (View → Show Rulers) and your layout boundaries 
are showing (View → Show Layout Boundaries).

Go to View → Show Layouts, and select the Blank page layout. Click New Layout and 
give your layout a meaningful name. Click the ruler running vertically along the edge 
of your page, and holding down your mouse button, drag to the right. A blue guide line 
will appear—drag it to 30pt (use the yellow info box that appears to help you get to the 
right spot). Add another guide line the same way, but position it at 994pt. Now drag 
from the ruler running along the top to add horizontal guides at 30pt and 719pt.

Add a text box to the page, and in the Layout Inspector, turn on “Enable on pages using 
this layout”—this will let you change the size and position of the text box on individual 
pages as needed, to accommodate the rest of the content on the page. In the Tag drop-
down, choose “body.”
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Figure 5-4. At this point, you should have four guide lines and two linked text boxes on 
your layout page.

Make the text box about 468 points wide and 630 points tall. Position it so it’s centered 
vertically on the page (a blue guide will pop up cutting through the middle of your text 
box when you get to the right spot) and its left edge is flush with the left vertical guide.

Next select your text box, and click the little blue arrow on the right edge, near the 
bottom, and then click again in the blank space on the right side of the page. When you 
click, Author adds a new text box linked to your first. Drag it so that it is also centered 
vertically and its right edge is flush with the guide at 994pt. Figure 5-4 shows what your 
layout should look like.

Now go to Toolbar → Shapes, and insert a line.

Align the line with the guide at the top of the page. Hold down shift and drag the ends 
of the line until it’s also aligned to the guides running vertically. (Holding down the 
Shift key keeps the line straight.)

In the Graphic Inspector, make the stroke a 5-point solid line at about 50 percent black 
(medium gray). Then with the line still selected, choose Arrange → Lock. You now have 
a nice header rule to run on every page that uses this layout.
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“Rule” is just design terminology for a line.

Now let’s add a running footer that includes the page number. Insert a new text box 
(Toolbar → Text Box). Drag it down to the bottom of the page and resize it so the edges 
are flush with the vertical guidelines, the bottom is flush with the bottom of the page, 
and the top with the bottom guideline.

Click the placeholder text in the text box, and choose Insert → Page Number. The 
current page number will appear in your box. Align the page number in the center using 
the align buttons in the Format Bar. Then select the number, and in the Format Bar 
change the font family to Helvetica, size 14 points, and color about 50 percent black 
(that is, medium gray). Right-click or control-click the page number and choose “Create 
Paragraph Style from Selection.” Give your new style a name (like Page Number or 
Folio) and hit OK.

Figure 5-5. You’ve now added a top and bottom rule and a running footer containing the 
current page number of the page you’re on.
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With the text box still selected, open the Text Inspector. Go to the More tab and give 
the text box a solid .5-point black top border, with an Offset of –2 points. Choose 
Arrange → Send to Back and the Arrange → Lock. The basic page layout is all set 
(Figure 5-5), so now it’s time to move on to the pages themselves.

Toggle the Layout Boundaries on and off (by typing Shift-Command-L) to see 
your text box edges and help get the alignment right.

Step 2: Add the Image Gallery
Click the thumbnail for page 4 in the Book menu, click the little arrow that appears, 
and choose your new page layout from the drop-down list. Do the same for page 5.

In the editing window for page 4, select and delete the text box on the left side of the 
page, and resize the text box on the right so it’s about 360 points wide (but make sure 
its right edge is still flush with the right edge of the top and bottom rules). Then click 
the Widgets button on the Toolbar and choose Gallery.

Select the Widget box and then shift-click to select the text box as well, and choose 
Arrange → Align Objects → Top. Then drag the Gallery box over so its left edge is even 
with the left endpoint of your top and bottom rules (a blue guide will show up connecting 
them when you get to the right spot).

Select the Gallery box and open the Widget Inspector. In the Layout tab, choose Bottom 
from the Layout drop-down menu, turn off Background, and drag the Margin slider 
down to 0. Grab the bottom-right resize handle and resize the widget so it’s 565 points 
wide and 630 points tall (or use the Metrics Inspector; see Figure 5-6).

Click the Gallery title and type Grasslands. Select your new caption and in the Format 
Bar, change the font family to Helvetica and change the color to black. Open the Styles 
Drawer (View → Show Styles Drawer) and find the paragraph style being used—it 
should be Figure Title. Click the red arrow next to the style name, and choose “Redefine 
Style from Selection.” All your sidebar captions will now use Helvetica and be black.

Next select the Gallery Label. Change the font to Helvetica Bold 15 point, and choose 
a nice, rich orangeish red from the color picker. Go to Format → Font → Capitalization, 
and choose Title. Leave the label selected, and in the Styles Drawer, find the Figure Label 
character style. Being careful not the click the style name, click the little arrow next to 
it, and choose “Redefine Style from Selection.” All your Widget labels will now use this 
new style (unless you change them in the Widget Inspector).

Creating Complex Layouts (Tutorial) | 77



Figure 5-6. Use the Metrics Inspector (the ruler icon) to get precise sizes and positions for 
the elements on your page.

If you want to get rid of that pesky label number, the way it is in Life on Earth, you’ll 
have to manually insert the label. In the Widget Inspector, choose None from the Label 
drop-down menu. Then type the word “Gallery” (page 59) and a space, select it, and 
apply your redefined Figure Label character style.

Click the caption and add your caption text. Then select the text, and in the Format Bar 
choose Palatino from the font family, Italic for the face, size it to 15 points, and make 
it black (Figure 5-7).

Step 3: Add the Body Text
Add some text to the remaining text box on page 4, select just one paragraph or all of 
it, and style it Palatino Regular 16 point. Then find the Body paragraph style in the Styles 
Drawer, click the red arrow, and choose “Redefine Style from Selection.”

78 | Chapter 5: Layouts



Figure 5-7. Here’s how page 4 looks with the finished image gallery.

Add a new paragraph at the top of the text box, and type Grasslands. Apply the Heading 
2 paragraph style, then select the paragraph text and style it Helvetica Bold 18 point 
black. Open the Text Inspector, and on the Text tab, drag the After Paragraph slider to 
0 points. With your paragraph still selected, find the Heading 2 paragraph style in the 
Styles Drawer, click the arrow and choose “Redefine Style from Selection.”

Now move over to page 5. Delete the text box on the right side of the page and resize 
the remaining box so there’s about an inch of space at the bottom. Your layout should 
look like Figure 5-8.

Step 5: Add Movie #1
Still on page 5, insert a Media Widget (Widgets → Media). You should notice that the 
label and caption look the same as the ones you styled for the Gallery on page 4. Align 
the Movie with the top of the text box and the right edge of the top and bottom rules. 
Resize it so there’s just a small gap between the Movie and the text box.

Select the Movie and open the Widget Inspector. In Layout, choose Top from the drop-
down, and then turn off the Caption checkbox (you may need to readjust the Movie 
position on the page after you do this), Turn off Background, and drag the Margin slider 
to 0. Resize the box to 350 points high (Figure 5-9).
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Figure 5-8. Pages 4 and 5, complete with text.

Figure 5-9. Page 5 with the boxed movie.

Again, to get rid of the label number entirely, you’ll need to delete the whole thing and 
retype it.
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Step 6: Add Movie #2
Now for that Earth-shaped movie. Insert another Media Widget, and immediately open 
the Widget Inspector. On Interaction, turn on the “Full-screen only” checkbox. Then 
in Layout, choose Freeform from the drop-down, turn off Background, and drag the 
Margin slider to 0.

On the page, click the gray movie icon. Size it to 665 points wide and 480 points tall, 
and move it to x: –364pt, y: 310pt. With the movie holder still selected, choose For
mat → Image → Mask with Shape → Oval. Resize the oval mask to 480 points by 480 
points, and make sure its position is x: –109pt, y: 310pt. (If the mask and movie place
holder get misaligned, click the movie placeholder and drag it into place within the oval 
mask.)

Move the movie title next to the right edge of the oval mask, with just a little space 
between them. Make it 537 points wide, and as small as possible to just fit the text. Go 
to the Wrap Inspector and type 0 in the Extra Space box. Select the caption box and 
make it 537 points wide as well, and tall enough to fit three lines of text. Set the Extra 
Space to 0 in the Wrap Inspector, and move it just below the title text box. Select both 
boxes, and choose Arrange → Align Objects → Left. Select both boxes, and set the x 
position to 382 points.

Just for Once: Don’t Worry About File Size
Remember that warning about movies and file size (see “Watch Your File Size” (page 
62)). Well, don’t fear: You’re not actually inserting the movie file twice into your book. 
Author doesn’t embed images, audio, or movies into your pages; instead, it saves the 
media file in a special folder and just links to it. So when you copy the image holder, you’re 
just adding a second link to the same movie file—a second place to play the file. Think of 
it like TV—the TV station broadcasts from one location, but it gets shown on lots of TVs.

If you actually have video content to place in your movie frame, select the movie box 
and click Edit Media—Author opens up a blank overlay where you can add your movie 
file by dragging and dropping it into place. Once you’ve added a file, the Widget In
spector gives you some options in the Interaction tab. Set positions in the movie to start 
and stop playing (for example, if you want to skip a few seconds at the beginning). Use 
the Poster Frame slider to choose a still frame to represent your movie in your text, and 
choose whether or not to loop your movie in the Repeat drop-down (Figure 5-10).

Unfortunately, getting an image to span two pages isn’t as easy as it would seem. You 
actually have to place two images—one on each page—and arrange them so they overlap 
perfectly. Select the oval mask and press command-C to copy it. Then go to page 4, click 
in some white space (to deselect your Movie Widget), and press command-V. Your 

Creating Complex Layouts (Tutorial) | 81



Figure 5-10. When you add a movie to the Movie widget, you can control how it appears 
when it’s not playing and how your readers interact with the movie.

masked movie image is added to the page. Click it and drag it over to the edge of the 
page. Slowly drag it to the correct position. This takes some finesse, but when you get 
close, Author can sense what you’re trying to do and will snap the duplicate image into 
the right position. Just make sure your cursor stays on page 4 while you’re dragging; if 
at any point your cursor crosses over to page 5, the copied image will cross over to page 
5 as well. See Figure 5-11 for the finished pages.

If you really screw up a page or an entire section or chapter, you can revert to 
the original layout. Hover over the page thumbnail in the Book menu and then 
click the little arrow that appears to the right. Choose “Reapply Layout” to get 
back to square one. This won’t delete any extra stuff you’ve added, like sidebars, 
images, tables, or text; it’ll just get the basic page structure looking the way it 
used to.
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Figure 5-11. Here are the finished pages, with placeholders for two movies, an image 
gallery, and some body text.
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CHAPTER 6

Publish Your Book

Your pages have been meticulously constructed. Your design is gorgeous. Your table 
of contents is a navigational miracle. Your widgets are a revelation. Now comes the fun 
part: it’s time to publish your book! Or maybe it’s not so fun.... If you want to self-publish 
in the iBookstore, you’re going to have to jump through a few hoops first. In this chapter, 
you’ll learn how to keep the hoop jumping manageable. You’ll see what Apple’s re
quirements are and how you can go about meeting them.

Previewing Your Book on the iPad
Before you think about publishing, take a few minutes to preview your creation on the 
iPad to make sure that everything is showing up and working as you expect. Happily, 
Author has a simple tool that makes previewing your work on an actual device easy as 
pie. Just follow these steps:

1. Make sure you’ve installed iBooks 2.0, available in the App Store, on your iPad.
2. Use a USB cord to connect your iPad to your Mac.
3. Open iBooks on your iPad.
4. Back in Author, click the Preview icon, which is a small thumbnail of an iPad screen.

The file will immediately start downloading to iBooks on your iPad. Download status 
is represented by a small purple progress bar within the iBooks interface.

You can limit the preview to a single chapter by highlighting that chapter in the 
Author sidebar and then selecting File → Preview Current Section Only.
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Carefully preview each page, and be sure to take the time to view all sections in both 
portrait and landscape views. If anything looks amiss, you can always make adjustments 
in Author and then push out another update to iBooks. Author makes updating and 
retesting so seamless that you can easily play around with multiple iterations of your 
page layouts until everything looks just right. Don’t forget to check the following:

• All page layouts, in both portrait and landscape views, should be working as ex
pected.

• All interactive widgets should be functional.
• All index and glossary entries should be successfully linked.
• The table of contents should be structured and functioning correctly; all sections 

should be nested correctly within chapters.
• All typos and grammatical errors should have been corrected—proofread, proof

read, proofread.

Share It!
Even after you think you’ve fixed everything and attended to every last detail, ask a trusted 
friend or colleague to review the pages for you. Even the most experienced publishing 
professional will tell you that another pair of eyes is essential in catching errors. Author 
makes this particularly easy with the Share option, available from the main menu. Just 
select Share → Send via Mail and Author will automatically export an iBooks Author file 
for Mac, an iBooks for iPad file, or a PDF and attach it to a message in your default email 
application. Be warned, though: the iBooks file options can be too large for email, so a 
PDF might be a better option. Those reviewing the PDF file will miss out on the interactive 
features that your book offers, but they’ll still be able to review all text, images, and land
scape layout. You can also export a plain text file, which might be the ideal choice to send 
to your favorite proofreader.

As you’re previewing your book on your iPad, take some screenshots that you can use 
when you upload your book via iTunes Producer, as described in “Packaging Up Your 
Book with iTunes Producer” (page 91). Once you’ve finished your review, you’re ready 
to submit your book to the Apple iBookstore.

Submitting Your Book to the iBookstore
As you make your way through the occasionally complex process of publishing your 
book to the iBookstore, you might amuse yourself by imaging that you are putting 
together a 1000-piece puzzle. Just when you think you’ll never get it, all the pieces start 
to snap into place.
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Figure 6-1. Choose wisely.

To view a simplified list of the submission requirements, click on the Publish icon in 
the Author interface and then choose “Learn more about publishing to the iBookstore.” 
When you choose this option, you open the iBooks Author Help Center and are taken 
to the “Publish your book to the iBookstore” section. The bulleted list of requirements 
that follows seems simple enough, but each step contains its own set of decisions and 
potential stumbling blocks:

• Set up an account in iTunes Connect (i.e., an iBookstore seller account).
• Download and install iTunes Producer.
• Establish an active contract with Apple.
• Prepare an excerpted sample version of your book.
• Publish to the iBookstore.

Seems simple enough, right? In some respects, it is simple, but Apple does not document 
all of the details in one place, making the submission process a little tricky, especially 
the first time you go through it. The following sections will help you navigate the process 
and make the best choices for you and your books.

Choosing Between a Paid and Free Account
The process for submitting a book to the iBookstore is influenced by whether you want 
to sell your books or give them away for free. You start the submission process by 
applying for an account on iTunes Connect. Making the choice between a Free Books 
Account and a Paid Books Account is your first big decision (Figure 6-1) and it will 
influence all of the steps that follow.
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You can offer both paid and free books through a Paid Books Account, but all books 
“sold” through a Free Books Account must be given away for free. Given those options, 
a Paid Books Account might seem like the obvious choice. However, there is consid
erably more red tape in setting up a Paid Books Account. Setting up a Free Books 
Account, on the other hand, takes little more than an Apple ID, which you already have 
if you’ve got an iTunes account.

Good to See You! ISBN Too Long!
An ISBN is an identifier that is unique to your book and is required by nearly all book 
retail channels, including the iBookstore. If you already have an ISBN for a print version 
of your book, you still must acquire an ISBN for the digital version of your book. Apple 
addresses this question directly in their FAQ for book publishers: “Print and digital edi
tions of the same book must have different ISBNs.”

Many publishers typically purchase ISBNs in large blocks of thousands. Over the last 
couple of years, purchasing a single ISBN has become easier. In the US, Bowker has a 
website service for this very task, which you can use to purchase an ISBN for $125. That 
price goes down if you purchase ISBNs in bulk. For example, you can buy 10 ISBNs for 
$250, which you should definitely consider if you’re planning to work on more than one 
book (and who isn’t!). Non-US residents can find out where to purchase ISBNs by looking 
up their national agency.

Wiley has a nice primer on ISBNs for self-publishers if you’d like to learn more.

When you set up a Paid Books Account, in addition to the requirements listed in the 
previous section, be prepared to provide information about the following:

• A US Tax ID, which you can apply for at the IRS website
• An ISBN that is unique to the digital version of the book (see the sidebar for more 

information about ISBNs)
• An account in the iTunes Store, with a credit card on file

Somewhat ominously, Apple informs you early in the process of applying for a Paid 
Books Account that you may be refused even if you meet all of the requirements:

Meeting these requirements and submitting an application does not guarantee that Apple 
will work directly with you. You may still be referred to an Apple-approved aggregator.

There is a further subtext to this short message that you should consider up front: you 
are entering into an agreement with Apple and, once you have, you are bound by their 
rules. Furthermore, there is some risk that you will go to the trouble of creating your 
book, applying for an account, and submitting your book and it will not be accepted 
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for sale in the iBookstore. While the review guidelines for books created with Author 
are still murky at the time of this writing, Apple routinely rejects iPhone and iPad 
applications for reasons such as poor quality and objectionable content. There is no 
reason to think that they won’t hold book creators to the same standards.

And don’t forget—Apple takes 30 percent of every sale you make through the 
iBookstore. Also, the iBooks Author EULA prohibits the sale of a file created 
with Author in any channel other than the iBookstore, although you can give it 
away for free (this restriction applies to the file format, not the content).

If you decide that creating a Paid Account isn’t right for your first project, you can 
always skip it, create a Free Account and give your book away for free (perhaps as a 
promotional vehicle for the print version?), and apply for a Paid Account at a later date.

You can potentially avoid an iBookstore seller account altogether and choose to go 
through one of Apple’s aggregators, each one of which has its own application process 
and potential setup and distribution fees. Be aware that, at the time of this writing, it is 
unclear how well positioned these aggregators are for distributing .ibooks files. The 
applications focus on generic EPUB rather than Apple’s new format. All things con
sidered, it seems that setting up an iBookstore account is your best bet.

Creating the Sample Book
Most major ebook retail channels now require anyone publishing an ebook to offer 
sample content. While in some cases the retailer will handle this step for you, with iBooks 
Author you must create your own sample book and include it with the book submission 
(Figure 6-2). Creating a sample version of your book is extra work for you, but it puts 
you in control of what appears as sample content. It is therefore an opportunity to 
connect with potential new readers.

So what belongs in your sample chapter? Readers (and your potential customers!) will 
download your sample chapter and browse through just a couple of pages. If something 
doesn’t grab them right away, they will move on to the next sample. Think carefully 
about the best features of your book, and make sure they’re the first thing a reader sees 
when she opens the book in iBooks. Here are some things to consider when choosing 
what to include in your sample:
Design

If your book is highly designed with complex page layouts, include the very best 
layouts in your sample.

Interactivity
Perhaps you’ve crafted an especially rich interactive experience for readers. If so, 
include a couple of those widgets right up front so that readers know your book 
will be something that they experience, not just consume.
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Figure 6-2. The Get Sample button is hard to miss; sample content is a requirement for 
all books in the iBookstore.

Your expertise, experience, and personality
Consider putting yourself front and center. Maybe the first thing readers see when 
they open the sample is a great picture of you, with a biography or list of credentials.

Unique promotional content
There’s no reason you couldn’t create a couple of special pages especially for the 
sample. Give a full page or two of what readers can expect from your book and mix 
in some screenshots from pages that aren’t included in the sample pages.

Once you’ve decided what to include in your sample book, actually creating it shouldn’t 
be too difficult if you’ve come this far. You can either simply delete everything except 
for the pages you don’t want in your sample or create an entirely new book and copy 
and paste sections or chapters into that book. If you choose the latter option, Author 
makes copying easy: simply right-click on the first page of any section or chapter 
thumbnail in the pages panel, and you will see the option to copy that section or chapter. 
Note that you cannot copy individual pages, so you will need to copy and paste at the 
section or chapter level.

If you set up your text boxes to flow together (see “Text Flow and Tags” (page 
72) in Chapter 3), then you’ll have to be careful with deleting pages. Depending 
on where you choose to start your sample, when you delete the pages before that, 
your text will jump forward to start in the text boxes that are left, shifting ev
erything further back. You’ll have to delete the text in addition to the pages 
themselves.

Once you have the sample ready, choose File → Export... and save it with the name of 
your choice as an .ibooks file. One more piece of the puzzle is in place!
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Packaging Up Your Book with iTunes Producer
To load your book to the iBookstore, you use a separate application called iTunes Pro
ducer, which you will only have access to after you have set up your Paid or Free Books 
Account.

Installing Producer and Creating a Package File
Once your account is created and approved by Apple, you can download Producer via 
iTunes Connect, a portal for managing your books that you access through a standard 
Internet browser (Figure 6-3). When you first log into iTunes Connect, take a moment 
to look around. Once you’ve submitted your book for publication in the iBookstore, 
you can use iTunes Connect to check the status of a book (whether it has been approved 
for sale, for example). You can also use the portal to track sales, make adjustments to 
the metadata of already submitted books, and so on. For now, however, you’re probably 
most interested in getting your book submitted, and to do that, you’ll need to download 
and install iTunes Producer. Within iTunes Connect, click on “Deliver Your Content” 
and you can grab the .dmg file for installation on your Mac.

Once iTunes Producer is installed, open it up and log in with the same account you 
used to access iTunes Connect. Stay logged in and leave iTunes Producer open, but 
switch back over to iBooks Author. On the iBooks Author toolbar, click the Publish 
icon (or you can use the main menu and select File → Publish if you’ve opted to remove 
that icon from your toolbar), and your book will start to export to an .itmsp file, which 
is an Apple iTunes Store package file. This package file will ultimately contain everything 
that you need to submit your book to the iBookstore, including the .ibooks book file, 
the sample book (which you’ll see how to add below), and all associated metadata.

If you are already logged into Producer, you will be taken to that application immedi
ately when you choose the Publish option within iBooks Author and the .itmsp file will 
be created automatically. If that doesn’t happen for some reason, you can simply save 
the .itmsp file to the location of your choice. Then, open or switch to Producer, log in 
(if necessary), and choose the “Open Package...” option. You can then choose 
the .itmsp file that you exported from iBooks Author.

Adding Metadata
In iTunes Producer, you add all of the metadata associated with your book (stuff like 
title, author name, price, and so on). Some of the metadata is required for submission 
to Apple, while you can ignore other items if you choose. Figure 6-4 shows the basic 
interface for entering metadata in Producer for a Paid Books Account.

For a quick peek of which metadata fields are required for submission to the iBookstore, 
you can click on the Delivery button within Producer, as shown in Figure 6-5.
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Figure 6-3. iTunes Connect allows you to manage and track books that you’ve submitted 
to Apple for publication in the iBookstore.

The required metadata fields for a Paid Account are as follows:

✓ ISBN ✓ Title

✓ The language in which the book is written ✓ A description of the book

✓ The publisher ✓ The publication date

✓ The number of pages ✓ Book category and subject

✓ The author ✓ Territory rights (i.e., the places you want to sell the book)

✓ Price  

If you opted for a Free Books Account, you don’t need (or even have the option) to enter 
an ISBN. Also, you will not see the Rights & Pricing tab, Related Products tab, or the 
Pre-order preview option (as shown in Figure 6-5). Otherwise, the iTunes Producer 
interface and requirements are the same.

92 | Chapter 6: Publish Your Book



Figure 6-4. Use iTunes Producer to enter metadata and load additional assets, such as 
your sample book.

Figure 6-5. You won’t be able to submit your book if you don’t provide the minimum 
metadata.

You can jump directly to the field within Producer by double-clicking on one of the 
items in the Delivery window panel (Figure 6-5). This method is a quick and easy way 
to fill in the required metadata fields for submission.
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The Book Description, a required (and crucially important for capturing cus
tomers) metadata field, supports only flat text. In other words, it does not support 
things like bulleted lists. Keep your descriptions to simple paragraphs and avoid 
fancy formatting, or it could end up looking like a mess once your book is released 
in the iBookstore.

You should consider going beyond the minimum requirements, though. Good meta
data directly correlates to “findability,” or the ease with which something can be found. 
Usually, this term is used in the context of the Internet, but in this case, you can think 
about it in relation to the iBookstore. The richer and more complete your metadata is, 
the easier it will be for your potential readers to find you. It is in your interest, therefore, 
to spend the time on your metadata to make it as complete as possible.

Most of the metadata fields are obvious, and you’ll have very little trouble filling them 
in. However, some of them could use a closer look:
Publication Date

If your book was previously published in physical form, it may be a good idea to 
use that date. On the other hand, if you’ve enhanced the original version with new 
content and interactive widgets, you may want to use the date that you are sub
mitting the book to the iBookstore. Ultimately, the decision is up to you. The ques
tion to ask yourself is: what date do I want my reader (and potential customers) to 
see?

Note that, in addition to a normal date, iTunes Producer will accept values such as 
“today,” “tomorrow,” “last year,” and so on.

Series Name and Number (not required)
If you’re planning on making this first book part of a series (e.g., Lord of the 
Rings), you can use these fields to indicate the title of that series and the number of 
this book in that series.

Display Number (not required)
Apple describes this value as “the display number as it should appear to customers 
on the iBookstore. For example, Book 4 or Volume III.”

Print Length
If your book has no print equivalent, consider using the page count from a PDF 
version of your book in iBooks Author.

Pre-order Previews Allowed (not required; Paid Accounts only)
You can submit your book to the iBookstore today and release it for sale at a later 
date using the Sales Start Date and Pre-Order Date fields on the Rights & Pricing 
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Figure 6-6. Upload your sample book to the Upload Publication Preview window.

tab. If you elect to have a pre-order period, you can allow readers to download the 
sample version of your book during that time, which will apply to all territories in 
which you will ultimately sell your book. Once your book is released, the sample 
book will also be available, regardless of whether you check this box or not.

You can read more details about each of the metadata fields in Apple’s documentation, 
available to you in iTunes Connect. The iTunes Producer User Guide is particularly 
helpful and can be downloaded from the “Deliver Your Content” section. You’ll also 
find training videos and other resources.

Adding Your Sample Book and Other Assets
The last step before you can finally hit the magic Deliver button is to load your sample 
chapter and potentially other assets. In iTunes Producer, click on Assets, and you’ll be 
presented with an option to load your sample book, as shown in Figure 6-6.

Simply click on Choose... and then select your sample chapter. You also can also use 
the Assets section of iTunes Producer to modify the Cover Art and add screenshots. 
Producer automatically grabs the cover from your .ibooks file, so no action is required.

Screenshots are optional, but strongly consider including them, particularly if you’ve 
got highly designed pages or visually appealing widgets. Figure 6-7 shows how screen
shots appear to readers browsing in the iBookstore.
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The book description and screenshots are your first and best chance to connect with 
potential new readers and customers. You can include up to five screenshots.

Once you have loaded your sample chapter and screenshots, click on the Delivery tab, 
and Producer will check to make sure that you’ve met all the requirements for submit
ting to the iBookstore. Clean up any remaining errors or problems. Once Producer is 
satisfied, the Deliver button will no longer be grayed out. Click it, and you’re done!

Figure 6-7. Screenshots in the iBookstore from Life on Earth show off both design and 
functionality.

Once your book and associated files and metadata have been sent to Apple, a review 
period begins. Apple normally reviews a book within a couple of days. If there is a 
problem, they will alert you via email or a notification via iTunes Connect.
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